View Issue Details

IDProjectCategoryView StatusLast Update
0000210OpenFOAM[All Projects] Bugpublic2011-06-06 12:13
Reporteruser202Assigned Touser2 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
PlatformIntel Desktop I7OSDebian Squeeze AMD64OS Version2.6.32-5-amd64
Product Version 
Fixed in Version 
Summary0000210: Tried to Compile from sources, it failed.
DescriptionA series of errors were reported.

Final errors were:
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude -fPIC Make/linux64GccDPOpt/equilibriumFlameT.o -L/opt/OpenFoam/OpenFOAM-1.7.1/lib/linux64GccDPOpt \
         -lspecie -lOpenFOAM -liberty -ldl -lm -o /opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/equilibriumFlameT
/usr/bin/ld: cannot find -lOpenFOAM
collect2: ld returned 1 exit status
make[2]: *** [/opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/equilibriumFlameT] Error 1
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/equilibriumFlameT'
make[1]: *** [equilibriumFlameT] Error 2
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
/bin/sh: /opt/OpenFoam/OpenFOAM-1.7.1/wmake/bin/linux64Gcc/wmkdep: not found
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
SOURCE=mixtureAdiabaticFlameT.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/mixtureAdiabaticFlameT.o
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude -fPIC Make/linux64GccDPOpt/mixtureAdiabaticFlameT.o -L/opt/OpenFoam/OpenFOAM-1.7.1/lib/linux64GccDPOpt \
         -lspecie -lOpenFOAM -liberty -ldl -lm -o /opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/mixtureAdiabaticFlameT
/usr/bin/ld: cannot find -lOpenFOAM
collect2: ld returned 1 exit status
make[2]: *** [/opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/mixtureAdiabaticFlameT] Error 1
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
make[1]: *** [mixtureAdiabaticFlameT] Error 2
make[1]: Target `application' not remade because of errors.
make[1]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical'
make: *** [thermophysical] Error 2
make: Target `application' not remade because of errors.
Steps To ReproduceFollowed the procedure on the web page for the source pack using the Allwmake script.
Additional InformationMore of the install log included as an attachment (which contains more errors)
TagsNo tags attached.

Activities

user202

2011-06-02 20:32

 

buildErrors.txt (8,105 bytes)
inux64GccDPOpt/adiabaticFlameT.o
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude   -fPIC Make/linux64GccDPOpt/adiabaticFlameT.o -L/opt/OpenFoam/OpenFOAM-1.7.1/lib/linux64GccDPOpt \
	     -lspecie -lOpenFOAM -liberty -ldl   -lm -o /opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/adiabaticFlameT
/usr/bin/ld: cannot find -lOpenFOAM
collect2: ld returned 1 exit status
make[2]: *** [/opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/adiabaticFlameT] Error 1
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/adiabaticFlameT'
make[1]: *** [adiabaticFlameT] Error 2
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/chemkinToFoam'
/bin/sh: /opt/OpenFoam/OpenFOAM-1.7.1/wmake/bin/linux64Gcc/wmkdep: not found
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/chemkinToFoam'
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/chemkinToFoam'
SOURCE=chemkinToFoam.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude     -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/reactionThermo/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64GccDPOpt/chemkinToFoam.o
In file included from chemkinToFoam.C:30:
/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/reactionThermo/lnInclude/chemkinReader.H:51:23: error: FlexLexer.h: No such file or directory
In file included from chemkinToFoam.C:30:
/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/reactionThermo/lnInclude/chemkinReader.H:66: error: expected class-name before '{' token
make[2]: *** [Make/linux64GccDPOpt/chemkinToFoam.o] Error 1
make[2]: Target `/opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/chemkinToFoam' not remade because of errors.
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/chemkinToFoam'
make[1]: *** [chemkinToFoam] Error 2
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/equilibriumCO'
/bin/sh: /opt/OpenFoam/OpenFOAM-1.7.1/wmake/bin/linux64Gcc/wmkdep: not found
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/equilibriumCO'
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/equilibriumCO'
SOURCE=equilibriumCO.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64GccDPOpt/equilibriumCO.o
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude   -fPIC Make/linux64GccDPOpt/equilibriumCO.o -L/opt/OpenFoam/OpenFOAM-1.7.1/lib/linux64GccDPOpt \
	     -lspecie -lOpenFOAM -liberty -ldl   -lm -o /opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/equilibriumCO
/usr/bin/ld: cannot find -lOpenFOAM
collect2: ld returned 1 exit status
make[2]: *** [/opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/equilibriumCO] Error 1
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/equilibriumCO'
make[1]: *** [equilibriumCO] Error 2
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/equilibriumFlameT'
/bin/sh: /opt/OpenFoam/OpenFOAM-1.7.1/wmake/bin/linux64Gcc/wmkdep: not found
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/equilibriumFlameT'
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/equilibriumFlameT'
SOURCE=equilibriumFlameT.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64GccDPOpt/equilibriumFlameT.o
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude   -fPIC Make/linux64GccDPOpt/equilibriumFlameT.o -L/opt/OpenFoam/OpenFOAM-1.7.1/lib/linux64GccDPOpt \
	     -lspecie -lOpenFOAM -liberty -ldl   -lm -o /opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/equilibriumFlameT
/usr/bin/ld: cannot find -lOpenFOAM
collect2: ld returned 1 exit status
make[2]: *** [/opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/equilibriumFlameT] Error 1
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/equilibriumFlameT'
make[1]: *** [equilibriumFlameT] Error 2
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
/bin/sh: /opt/OpenFoam/OpenFOAM-1.7.1/wmake/bin/linux64Gcc/wmkdep: not found
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
make[2]: Entering directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
SOURCE=mixtureAdiabaticFlameT.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64GccDPOpt/mixtureAdiabaticFlameT.o
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/OpenFoam/OpenFOAM-1.7.1/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OpenFOAM/lnInclude -I/opt/OpenFoam/OpenFOAM-1.7.1/src/OSspecific/POSIX/lnInclude   -fPIC Make/linux64GccDPOpt/mixtureAdiabaticFlameT.o -L/opt/OpenFoam/OpenFOAM-1.7.1/lib/linux64GccDPOpt \
	     -lspecie -lOpenFOAM -liberty -ldl   -lm -o /opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/mixtureAdiabaticFlameT
/usr/bin/ld: cannot find -lOpenFOAM
collect2: ld returned 1 exit status
make[2]: *** [/opt/OpenFoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/mixtureAdiabaticFlameT] Error 1
make[2]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
make[1]: *** [mixtureAdiabaticFlameT] Error 2
make[1]: Target `application' not remade because of errors.
make[1]: Leaving directory `/opt/OpenFoam/OpenFOAM-1.7.1/applications/utilities/thermophysical'
make: *** [thermophysical] Error 2
make: Target `application' not remade because of errors.

buildErrors.txt (8,105 bytes)

user19

2011-06-02 21:16

  ~0000416

Last edited: 2011-06-02 21:18

View 2 revisions

Unfortunately, this output is not sufficient. The actual error happened much earlier, and the missing OpenFOAM library is just a consequence of that earlier error. Try to run this command from the top-level source-directory and post the file log.txt:

./Allwmake 2>&1 | tee log.txt

Usually, the first error is the interesting one, and all subsequent errors are likely to be a consequence of this first error. Reporting the last error almost never is of any use.

user202

2011-06-03 02:07

 

log.txt (463,891 bytes)

user202

2011-06-03 02:10

  ~0000417

I tried this twice. The first time I noticed the log complained about not having something called flex loaded. I then added it via apt-get install flex. That got rid of that issue. However I still have errors. But perhaps the "flex" program should be added to a pre-instal checklist.

Either way, please let me know what you find on the attached log file.

user2

2011-06-03 09:07

  ~0000418

It looks as though you need to install zlib

/usr/bin/ld: cannot find -lz
...
db/IOstreams/gzstream/gzstream.h:35:18: error: zlib.h: No such file or directory

wyldckat

2011-06-04 20:04

updater   ~0000420

Greetings!

For the sake of "completeness", since Joshua is using Debian, here's a link with a list of packages that usually need to be installed in Ubuntu, which is based on Debian: http://www.cfd-online.com/Forums/openfoam-installation/88876-compilation-error-1-allwmake-ubuntu-11-04-a.html#post310074

If zlib is the only one missing, it can be installed by running as normal user:
  sudo apt-get install zlib1g-dev

Or as root:
  apt-get install zlib1g-dev

Best regards.

Issue History

Date Modified Username Field Change
2011-06-02 20:32 user202 New Issue
2011-06-02 20:32 user202 File Added: buildErrors.txt
2011-06-02 21:16 user19 Note Added: 0000416
2011-06-02 21:18 user19 Note Edited: 0000416 View Revisions
2011-06-03 02:07 user202 File Added: log.txt
2011-06-03 02:10 user202 Note Added: 0000417
2011-06-03 09:07 user2 Note Added: 0000418
2011-06-04 20:04 wyldckat Note Added: 0000420
2011-06-06 12:13 user2 Status new => resolved
2011-06-06 12:13 user2 Resolution open => no change required
2011-06-06 12:13 user2 Assigned To => user2