View Issue Details

IDProjectCategoryView StatusLast Update
0002095OpenFOAM[All Projects] Bugpublic2016-05-23 13:25
ReporterSam85Assigned Tochris 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformlinuxOSUbuntu OS Version15.10
Product Version 
Fixed in Version 
Summary0002095: Not installing now but did before
DescriptionI installed Openfoam on my laptop, it was and still is working fine. I have currently acquired a new desktop and tried the exact same installation as before but now Openfoam has not installed any folders passed the run folder and the tutorials are missing.

http://openfoam.org/download/3-0-1-ubuntu/
This is the link I have used to install the software each time following the commands.
TagsNo tags attached.

Activities

wyldckat

2016-05-19 14:53

updater   ~0006292

Are you 100% certain that the new desktop has Ubuntu 15.10?

Instructions on how to check which Ubuntu version is installed: https://help.ubuntu.com/community/CheckingYourUbuntuVersion

Sam85

2016-05-19 15:12

reporter   ~0006293

Yes I am running it as a virtual machine in the same way I did on my laptop

wyldckat

2016-05-19 18:19

updater   ~0006296

I believe I've spotted the issue, although I haven't tested this myself yet...
The problem is the link that is currently broken, namely this one: http://www.openfoam.org/download/ubuntu

wyldckat

2016-05-19 18:25

updater   ~0006297

Something else is amiss, because I tested indirectly the link and it seems to be working as intended.

@Sam85: Can you please let us know if there is anything installed in the folder "/opt/openfoam30"?

In addition, can you please provide the output from this command:

  sudo apt-get install openfoam30

Sam85

2016-05-20 12:37

reporter   ~0006299

W: The repository 'http://www.openfoam.org/download/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://download.openfoam.org/ubuntu/dists/xenial/main/binary-amd64/Packages 404 Not Found
E: Failed to fetch http://download.openfoam.org/ubuntu/dists/xenial/main/binary-i386/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Sam85

2016-05-20 12:38

reporter   ~0006300

This is an error I have received when trying to re-install

wyldckat

2016-05-20 20:37

updater   ~0006301

Hi Sam85,

I've tested just now in a VM with Ubuntu 15.10 and it worked without any problems. But... Remember when I asked you this question?

> Are you 100% certain that the new desktop has Ubuntu 15.10?

Well, according to the output you've provided, you have "Ubuntu 16.04 Xenial Xerus" installed. Maybe you clicked on the "upgrade to 16.04" button after installing Ubuntu 15.10 inside the virtual machine?

Because, and unfortunately, this version of Ubuntu is not yet supported through OpenFOAM Deb packages, but it will be supported in the next version of OpenFOAM, as stated on the first comment here: http://bugs.openfoam.org/view.php?id=2070


In the meantime, you can either (re-)install Ubuntu 15.10 inside a virtual machine or you can build OpenFOAM 3.0.x from source code, by following either one of the following instructions:

  - http://openfoam.org/download/source/ - these are the official instructions for building/installing OpenFOAM 3.0.x and dev.

  - http://openfoam.org/download/3-0-1-source/ - these are for building/installing OpenFOAM 3.0.1 from source code.

  - http://openfoamwiki.net/index.php/Installation/Linux/OpenFOAM-3.0.1/Ubuntu#Ubuntu_16.04 - these are community written instructions, which are detailed and specific for 3.0.1.


If you have problems installing OpenFOAM through Deb packages on Ubuntu 15.10, please free to re-open this bug report!
In the meantime, I'll close this report for the time being.

Best regards,
Bruno

Sam85

2016-05-20 22:22

reporter   ~0006302

Hi Yes I know that it looks now like 16.04 was causing problems all along but unfortunately that is not the case. I reinstalled Ubuntu on my VMWare Workstation and tried the upgraded version to see if it would make a difference but it didn't. The initial issue was with 15.10 and still remains.

When I add this command mkdir -p $FOAM_RUN it does not work unless I close terminal and input again, then there are no sub folders after run (no tutorial folders) so when I try this command it does not find the folder.

cd $FOAM_RUN
cp -r $FOAM_RUN/tutorials/incompressible/simpleFoam/pitzDaily

Thanks

Sam

wyldckat

2016-05-21 00:38

updater   ~0006303

Hi Sam,

Mmm... OK, if you now have Ubuntu 15.10 working in the VM, then please provide the following details:


1. What do the following command lines give you?

    sudo add-apt-repository http://www.openfoam.org/download/ubuntu

    sudo apt-get update

    sudo apt-get install openfoam30


2. Does the following command give any output? And if it does, what is it?

    ls -l /opt/openfoam30/



3. If by any chance the previous command gave any output, then what do the following command lines give you?

    source /opt/openfoam30/etc/bashrc
    
    echo $FOAM_RUN


I ask these questions because I'm not able to reproduce the same error. Therefore, I need to somehow see/access what you're experiencing on your VM.

Best regards,
Bruno

Sam85

2016-05-23 09:27

reporter   ~0006305

Hi Bruno,

I have copied all the outcomes of the commands in terminal in the text below, I still have nothing in my run folder (tutorials are missing).

Best regards,
Sam

sam@ubuntu:~$ sudo add-apt-repository
[sudo] password for sam:
Error: need a repository as argument

sam@ubuntu:~$ sudo apt-get update
Hit http://security.ubuntu.com wily-security InRelease
Hit http://security.ubuntu.com wily-security/main Sources
Hit http://security.ubuntu.com wily-security/restricted Sources
Hit http://security.ubuntu.com wily-security/universe Sources
Hit http://security.ubuntu.com wily-security/multiverse Sources
Hit http://security.ubuntu.com wily-security/main amd64 Packages
Hit http://security.ubuntu.com wily-security/restricted amd64 Packages
Hit http://security.ubuntu.com wily-security/universe amd64 Packages
Hit http://security.ubuntu.com wily-security/multiverse amd64 Packages
Hit http://security.ubuntu.com wily-security/main i386 Packages
Hit http://security.ubuntu.com wily-security/restricted i386 Packages
Hit http://security.ubuntu.com wily-security/universe i386 Packages
Hit http://security.ubuntu.com wily-security/multiverse i386 Packages
Hit http://security.ubuntu.com wily-security/main Translation-en
Hit http://us.archive.ubuntu.com wily InRelease
Hit http://security.ubuntu.com wily-security/multiverse Translation-en
Ign http://www.openfoam.org wily InRelease
Hit http://security.ubuntu.com wily-security/restricted Translation-en
Hit http://security.ubuntu.com wily-security/universe Translation-en
Get:1 http://us.archive.ubuntu.com wily-updates InRelease [65.9 kB]
Ign http://www.openfoam.org wily Release.gpg
Ign http://www.openfoam.org wily Release
Hit http://us.archive.ubuntu.com wily-backports InRelease
Ign http://www.openfoam.org wily/main amd64 Packages/DiffIndex
Hit http://us.archive.ubuntu.com wily/main Sources
Ign http://www.openfoam.org wily/main i386 Packages/DiffIndex
Hit http://us.archive.ubuntu.com wily/restricted Sources
Hit http://us.archive.ubuntu.com wily/universe Sources
Hit http://us.archive.ubuntu.com wily/multiverse Sources
Hit http://us.archive.ubuntu.com wily/main amd64 Packages
Hit http://us.archive.ubuntu.com wily/restricted amd64 Packages
Hit http://us.archive.ubuntu.com wily/universe amd64 Packages
Hit http://us.archive.ubuntu.com wily/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com wily/main i386 Packages
Hit http://us.archive.ubuntu.com wily/restricted i386 Packages
Hit http://us.archive.ubuntu.com wily/universe i386 Packages
Hit http://us.archive.ubuntu.com wily/multiverse i386 Packages
Hit http://us.archive.ubuntu.com wily/main Translation-en
Hit http://us.archive.ubuntu.com wily/multiverse Translation-en
Hit http://us.archive.ubuntu.com wily/restricted Translation-en
Hit http://us.archive.ubuntu.com wily/universe Translation-en
Get:2 http://us.archive.ubuntu.com wily-updates/main Sources [79.8 kB]
Hit http://www.openfoam.org wily/main amd64 Packages
Hit http://www.openfoam.org wily/main i386 Packages
Get:3 http://us.archive.ubuntu.com wily-updates/restricted Sources [3,741 B]
Ign http://www.openfoam.org wily/main Translation-en_US
Ign http://www.openfoam.org wily/main Translation-en
Get:4 http://us.archive.ubuntu.com wily-updates/universe Sources [23.9 kB]
Get:5 http://us.archive.ubuntu.com wily-updates/multiverse Sources [3,196 B]
Get:6 http://us.archive.ubuntu.com wily-updates/main amd64 Packages [221 kB]
Get:7 http://us.archive.ubuntu.com wily-updates/restricted amd64 Packages [13.3 kB]
Get:8 http://us.archive.ubuntu.com wily-updates/universe amd64 Packages [96.4 kB]
Get:9 http://us.archive.ubuntu.com wily-updates/multiverse amd64 Packages [6,256 B]
Get:10 http://us.archive.ubuntu.com wily-updates/main i386 Packages [217 kB]
Get:11 http://us.archive.ubuntu.com wily-updates/restricted i386 Packages [13.4 kB]
Get:12 http://us.archive.ubuntu.com wily-updates/universe i386 Packages [93.8 kB]
Get:13 http://us.archive.ubuntu.com wily-updates/multiverse i386 Packages [6,687 B]
Get:14 http://us.archive.ubuntu.com wily-updates/main Translation-en [102 kB]
Get:15 http://us.archive.ubuntu.com wily-updates/multiverse Translation-en [3,156 B]
Get:16 http://us.archive.ubuntu.com wily-updates/restricted Translation-en [3,024 B]
Get:17 http://us.archive.ubuntu.com wily-updates/universe Translation-en [55.2 kB]
Hit http://us.archive.ubuntu.com wily-backports/main Sources
Hit http://us.archive.ubuntu.com wily-backports/restricted Sources
Hit http://us.archive.ubuntu.com wily-backports/universe Sources
Hit http://us.archive.ubuntu.com wily-backports/multiverse Sources
Hit http://us.archive.ubuntu.com wily-backports/main amd64 Packages
Hit http://us.archive.ubuntu.com wily-backports/restricted amd64 Packages
Hit http://us.archive.ubuntu.com wily-backports/universe amd64 Packages
Hit http://us.archive.ubuntu.com wily-backports/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com wily-backports/main i386 Packages
Hit http://us.archive.ubuntu.com wily-backports/restricted i386 Packages
Hit http://us.archive.ubuntu.com wily-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com wily-backports/multiverse i386 Packages
Hit http://us.archive.ubuntu.com wily-backports/main Translation-en
Hit http://us.archive.ubuntu.com wily-backports/multiverse Translation-en
Hit http://us.archive.ubuntu.com wily-backports/restricted Translation-en
Hit http://us.archive.ubuntu.com wily-backports/universe Translation-en
Fetched 1,008 kB in 13s (76.8 kB/s)
Reading package lists... Done

sam@ubuntu:~$ sudo apt-get install openfoam30
Reading package lists... Done
Building dependency tree
Reading state information... Done
openfoam30 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 224 not upgraded.

sam@ubuntu:~$ ls -l /opt/openfoam30/
total 84
-rwxr-xr-x 1 root root 1256 Dec 12 07:27 Allwmake
drwxr-xr-x 5 root root 4096 May 20 04:39 applications
drwxr-xr-x 3 root root 4096 May 20 04:39 bin
-rw-r--r-- 1 root root 0 Dec 12 08:14 build-stamp
-rw-r--r-- 1 root root 35647 Dec 12 07:27 COPYING
drwxr-xr-x 6 root root 4096 May 20 04:39 doc
drwxr-xr-x 7 root root 4096 May 20 04:39 etc
drwxr-xr-x 3 root root 4096 May 20 04:39 platforms
-rw-r--r-- 1 root root 7645 Dec 12 07:27 README.html
-rw-r--r-- 1 root root 1471 Dec 12 07:27 README.org
drwxr-xr-x 36 root root 4096 May 20 04:39 src
drwxr-xr-x 16 root root 4096 May 20 04:39 tutorials
drwxr-xr-x 6 root root 4096 May 20 04:39 wmake

sam@ubuntu:~$ source /opt/openfoam30/etc/bashrc
sam@ubuntu:~$ echo $FOAM_RUN
/home/sam/OpenFOAM/sam-3.0.1/run
sam@ubuntu:~$

wyldckat

2016-05-23 10:17

updater   ~0006306

Hi Sam,

The good news is that OpenFOAM is indeed installed with success!

Make sure you have followed the instructions given in section "User Configuration" to finish the installation steps: http://openfoam.org/download/3-0-1-ubuntu/#user-configuration

Then please follow the instructions given in the section "Getting Started": http://openfoam.org/download/3-0-1-ubuntu/#getting-started

Best regards,
Bruno

Sam85

2016-05-23 10:38

reporter   ~0006307

Hi Bruno,

That is good that it has installed, how do I locate the tutorial folder?

As I said before I have followed the instructions and installed the software previously on my laptop with no problems, however this time after installing openfoam on my desktop I can not locate the tutorial files the run folder is empty?

Best regards

Sam

sam@ubuntu:~$ cd $FOAM_RUN
sam@ubuntu:~/OpenFOAM/sam-3.0.1/run$ cp -r $FOAM_RUN/tutorials/incompressible/simpleFoam/pitzDaily
cp: missing destination file operand after ‘/home/sam/OpenFOAM/sam-3.0.1/run/tutorials/incompressible/simpleFoam/pitzDaily’
Try 'cp --help' for more information.
sam@ubuntu:~/OpenFOAM/sam-3.0.1/run$

wyldckat

2016-05-23 10:48

updater   ~0006308

Hi Sam,

Sorry, I didn't notice the bug that is written in the section "Getting Started". The correct copy command is this:

  cp -r $FOAM_TUTORIALS/incompressible/simpleFoam/pitzDaily .

Notice that there is a dot at the end.
The bug is that it is stating "$FOAM_RUN/tutorials" when it should be "$FOAM_TUTORIALS".

In addition to this, the introductory part of chapter 2 has the details needed for making a full copy of the "tutorials" folder: http://cfd.direct/openfoam/user-guide/tutorials/#x4-30002

I'll give a heads-up to Chris, the maintainer of the website, regarding this bug/typo.

Best regards,
Bruno

Sam85

2016-05-23 10:54

reporter   ~0006309

Hi Bruno,

Thank you I have run a simulation and it is all working fine now, the tutorial folders are there.

Many Thanks

Sam

chris

2016-05-23 13:25

manager   ~0006310

Fixed the error in "Getting Started" across all download/installation pages.

Issue History

Date Modified Username Field Change
2016-05-19 14:12 Sam85 New Issue
2016-05-19 14:53 wyldckat Note Added: 0006292
2016-05-19 15:12 Sam85 Note Added: 0006293
2016-05-19 18:19 wyldckat Note Added: 0006296
2016-05-19 18:20 wyldckat Assigned To => chris
2016-05-19 18:20 wyldckat Status new => assigned
2016-05-19 18:23 wyldckat Assigned To chris =>
2016-05-19 18:25 wyldckat Note Added: 0006297
2016-05-19 18:25 wyldckat Assigned To => wyldckat
2016-05-19 18:25 wyldckat Status assigned => new
2016-05-20 12:37 Sam85 Note Added: 0006299
2016-05-20 12:38 Sam85 Note Added: 0006300
2016-05-20 20:37 wyldckat Note Added: 0006301
2016-05-20 20:38 wyldckat Status new => closed
2016-05-20 20:38 wyldckat Resolution open => suspended
2016-05-20 20:38 wyldckat Fixed in Version => Other
2016-05-20 22:22 Sam85 Note Added: 0006302
2016-05-20 22:22 Sam85 Status closed => feedback
2016-05-20 22:22 Sam85 Resolution suspended => reopened
2016-05-21 00:38 wyldckat Note Added: 0006303
2016-05-23 09:27 Sam85 Note Added: 0006305
2016-05-23 09:27 Sam85 Status feedback => assigned
2016-05-23 10:17 wyldckat Note Added: 0006306
2016-05-23 10:38 Sam85 Note Added: 0006307
2016-05-23 10:48 wyldckat Note Added: 0006308
2016-05-23 10:48 wyldckat Assigned To wyldckat => chris
2016-05-23 10:54 Sam85 Note Added: 0006309
2016-05-23 13:25 chris Note Added: 0006310
2016-05-23 13:25 chris Status assigned => resolved
2016-05-23 13:25 chris Resolution reopened => fixed