View Issue Details

IDProjectCategoryView StatusLast Update
0002089OpenFOAMPatchpublic2016-05-15 18:14
ReporterwyldckatAssigned Tohenry 
PrioritylowSeveritytextReproducibilityN/A
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Versiondev 
Summary0002089: A few textual updates for scripts related to issue #1232 and writeRegisteredObject example file
DescriptionThe original reason for this report is that there are no instructions on how to disable Scotch and CGAL, at least on the user-side, given that Boost and Scotch versions are loaded directly from within a few Allwmake scripts.

For example, if the user chooses to not build the decomposition libraries with Scotch or does not want to use system's Boost (e.g. for building SloanRenumber), then it's not clear how this can be disabled.

Therefore, brief instructions on how to do this are detailed in the respective scripts, provided inside the attached tarball "various_text_fixes.tar.gz". The instructions are somewhat cryptic, but this is because I ended up using a similar description as used in the "etc/config.sh/example/paraview".

In addition, I've spotted a few additional small missing textual details for the following files, for which fixes are in the tarball:

  - etc/config.csh/CGAL - Missing line break at the bottom of the header.
  - etc/config.csh/paraview - Missing line break at the bottom of the header.
  - etc/config.sh/CGAL - Missing instructions on how to disable.
  - etc/config.sh/example/paraview - Missing period at the end of the header.
  - etc/config.sh/metis - Missing line break at the bottom of the header.
  - etc/config.sh/scotch - Missing instructions on how to disable.
  - src/postProcessing/functionObjects/utilities/writeRegisteredObject/controlDict - Missing semi-colon in example code. This was spotted because there is a detail missing in this function object, which I'll report as soon as possible.
Additional InformationI picked up on this from a comment at develop.openfoam.com, issue #119, where it was pointed out that since "boost-system" is set by default, it will always try to build at least SloanRenumber, assuming of course that FOAMY_HEX_MESH is set.
TagsNo tags attached.

Activities

wyldckat

2016-05-15 01:00

updater  

various_text_fixes.tar.gz (3,876 bytes)

henry

2016-05-15 18:14

manager   ~0006275

Thanks Bruno
Resolved by commit 855ce5b73550f94517334b9af815390cb861d92a

Issue History

Date Modified Username Field Change
2016-05-15 01:00 wyldckat New Issue
2016-05-15 01:00 wyldckat Status new => assigned
2016-05-15 01:00 wyldckat Assigned To => henry
2016-05-15 01:00 wyldckat File Added: various_text_fixes.tar.gz
2016-05-15 18:14 henry Note Added: 0006275
2016-05-15 18:14 henry Status assigned => resolved
2016-05-15 18:14 henry Fixed in Version => dev
2016-05-15 18:14 henry Resolution open => fixed