View Issue Details

IDProjectCategoryView StatusLast Update
0002088OpenFOAMPatchpublic2016-05-13 16:26
ReporterMattijsJAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOpenSuSEOS Version13.2
Product Versiondev 
Fixed in Versiondev 
Summary0002088: checkMesh reports ACMI cases as having open cells
DescriptioncheckMesh says boundary and cells are open for ACMI cases.

This is due to the geometry being cleared out instead of updating the geometry. Attached
- utilities/mesh/manipulation/checkMesh/checkMesh.C : remove clearOut of mesh
at first timestep (any others are already done inside the mesh.readUpdate)

- polyMeshIO.C : when re-reading points make sure to update the boundary geometry.

I haven't checked this on a moving case yet.
Steps To ReproduceoscillatingInletACMI2D tutorial
TagsNo tags attached.

Activities

MattijsJ

2016-05-13 14:22

reporter  

polyMeshIO.C (12,017 bytes)

MattijsJ

2016-05-13 14:22

reporter  

checkMesh.C (5,761 bytes)

MattijsJ

2016-05-13 15:18

reporter   ~0006268

In

tutorials/incompressible/pimpleDyMFoam/oscillatingInletACMI2D/system/controlDict

we also want to increase the writePrecision since otherwise it still reports open cells. E.g.


writePrecision 10;

henry

2016-05-13 16:26

manager   ~0006269

Resolved by commit 90ba6113b597880dd3200bd37284627302bf9cc7

Issue History

Date Modified Username Field Change
2016-05-13 14:22 MattijsJ New Issue
2016-05-13 14:22 MattijsJ File Added: polyMeshIO.C
2016-05-13 14:22 MattijsJ File Added: checkMesh.C
2016-05-13 15:18 MattijsJ Note Added: 0006268
2016-05-13 16:26 henry Note Added: 0006269
2016-05-13 16:26 henry Status new => resolved
2016-05-13 16:26 henry Fixed in Version => dev
2016-05-13 16:26 henry Resolution open => fixed
2016-05-13 16:26 henry Assigned To => henry