View Issue Details

IDProjectCategoryView StatusLast Update
0001992OpenFOAM(No Category)public2016-02-15 14:22
ReporterjacobAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOpenSuSEOS Version13.2
Product Version 
Fixed in Version 
Summary0001992: Flex 2.6+ not supported
DescriptionFlex source files, e.g. readSTLASCII.L contain conditions

#if YY_FLEX_SUBMINOR_VERSION < 34

which are specific to Flex 2.5. However, the newest available version has subminor again less than 34, so the code fails.
Steps To ReproduceTry to compile OpenFOAM with Flex 2.6+
TagsNo tags attached.

Activities

henry

2016-02-12 15:41

manager   ~0005939

This is already fixed in OpenFOAM-dev:

commit a4eabffbacfa8e4648f044e3d4c2a74d722a2b47
Author: Henry Weller <http://cfd.direct>
Date: Mon Jan 18 19:44:38 2016 +0000

    Add support for flex-2.6
    Resolves bug-report http://www.openfoam.org/mantisbt/view.php?id=1974

I can make the same change to OpenFOAM-3.0.x if needed.

henry

2016-02-15 14:22

manager   ~0005945

Resolved in OpenFOAM-3.0.x by commit 31185852095c0a67e516dfb0d0b1d634955bb617

Issue History

Date Modified Username Field Change
2016-02-12 14:54 jacob New Issue
2016-02-12 15:41 henry Note Added: 0005939
2016-02-15 14:22 henry Note Added: 0005945
2016-02-15 14:22 henry Status new => resolved
2016-02-15 14:22 henry Fixed in Version => 3.0.x
2016-02-15 14:22 henry Resolution open => fixed
2016-02-15 14:22 henry Assigned To => henry
2016-03-11 11:44 administrator Category 3.0.1 => (No Category)