View Issue Details

IDProjectCategoryView StatusLast Update
0001968OpenFOAM(No Category)public2016-02-16 17:40
ReporterGreatTunaAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSCentOS OS Version6.5
Product Version 
Fixed in Version 
Summary0001968: Dummy turbulence model
DescriptionHi,

I have just tried setting a dummy turbulence model using a buoyantBoussinesqsimpleFoam (laminar) - and it could not find it. i.e. it insisted from me of choosing one of the turbulence models.

Having it in did make my life setting the cases up much easier.

Regards,
GT
Additional InformationN/A
TagsNo tags attached.

Activities

henry

2016-01-08 11:18

manager   ~0005819

In OpenFOAM-3.0.x and OpenFOAM-dev

set

simulationType laminar;

in constant/turbulenceProperties

commit 30fcaa0e852d86585b99e5db572940548af3ebb3
Author: Henry Weller <http://cfd.direct>
Date: Wed Dec 16 10:23:03 2015 +0000

    solvers: Change from pure RAS to any turbulence model
    Provides support for running laminar.

GreatTuna

2016-02-16 15:28

reporter   ~0005951

Last edited: 2016-02-16 15:29

View 2 revisions

Sorry for the delay. I am handling multiple CFD codes at once at the moment.

I did that. It did not seem to make any effect. Setting RASModel to laminar also brought an error offering a list of list of models. Turning off turbulence - gives a weird results, not what I am expecting or used to get with previous version and Fluent.

P.S. I know some of the settings are fairly silly which are shown in the log below.

CODES:

simulationType laminar;

RAS
{
    RASModel kEpsilon;

    turbulence on;

    printCoeffs on;
}

RECEIVED THIS:
 
/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 3.0.1 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Build : 3.0.1-d8a290b55d28
Exec : buoyantBoussinesqSimpleFoam
Date : Feb 16 2016
Time : 15:24:46
Host : "cslin229.csunix.comp.leeds.ac.uk"
PID : 2038
Case : /usr/not-backed-up/scegr/PhD/OpenFOAM/scegr-3.0.1/wavy_cyclic_re_200-v3
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Allowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0


SIMPLE: convergence criteria
    field p_rgh tolerance 9.9999999999999994515e-21
    field U tolerance 9.9999999999999994515e-21
    field T tolerance 9.9999999999999994515e-21
    field "(k|epsilon|omega)" tolerance 9.9999999999999994515e-21

Reading thermophysical properties

Reading field T

Reading field p_rgh

Reading field U

Reading/calculating face flux field phi

Selecting incompressible transport model Newtonian
Creating turbulence model

Selecting RAS turbulence model kEpsilon
kEpsilonCoeffs
{
    Cmu 0.089999999999999996669;
    C1 1.4399999999999999467;
    C2 1.9199999999999999289;
    C3 -0.33000000000000001554;
    sigmak 1;
    sigmaEps 1.3000000000000000444;
}

Reading field alphat


Reading g

Reading hRef
Calculating field g.h

No MRF models present

Creating finite volume options from "system/fvOptions"

Selecting finite volume options model type meanVelocityForce
    Source: momentumSource
    - selecting all cells
    - selected 11092 cell(s) with volume 2.1638718138258682131e-09
    Initial pressure gradient = 0


Starting time loop

Time = 1

DILUPBiCG: Solving for Ux, Initial residual = 0.99999999928062910381, Final residual = 0.015835822072799751736, No Iterations 1
DILUPBiCG: Solving for Uy, Initial residual = 0.99999999999995681232, Final residual = 0.016064443960007196432, No Iterations 1
Pressure gradient source: uncorrected Ubar = 0.65491093993996307709, pressure gradient = 54849.896026251517469
DILUPBiCG: Solving for T, Initial residual = 0.99999999999690358798, Final residual = 0.055651525139043291068, No Iterations 1
DICPCG: Solving for p_rgh, Initial residual = 0.99999999999998900879, Final residual = 0.0087837772772507601016, No Iterations 123
Pressure gradient source: uncorrected Ubar = 0.65638578853558571247, pressure gradient = 46831.776236798279569
time step continuity errors : sum local = 3.6815159504775434307, global = 4.8348632423557016773e-06, cumulative = 4.8348632423557016773e-06
DILUPBiCG: Solving for epsilon, Initial residual = 0.088680337636747333385, Final residual = 0.0081414530805424614734, No Iterations 1
DILUPBiCG: Solving for k, Initial residual = 0.9999999999998835376, Final residual = 0.016398666909549365622, No Iterations 2
ExecutionTime = 0.11000000000000000056 s ClockTime = 0 s

Time = 2

henry

2016-02-16 16:10

manager   ~0005952

Already fixed in OpenFOAM-dev and OpenFOAM-3.0.x.

GreatTuna

2016-02-16 17:13

reporter   ~0005953

Sorry for reopening again.

I am using 3.0.1 at the moment - as can be seen from the extracted data in my previous message.

I double checked everything - it works using simpleFOAM, but using buoyantBoussinesqSimpleFOAM - does NOT react to setting of simulationType laminar;

I assume that there is some minor difference in these two apps I cannot spot, as I am not the expert on C++.

GreatTuna

2016-02-16 17:14

reporter   ~0005954

I can make a link to a case file on a could if needed.

henry

2016-02-16 17:39

manager   ~0005955

I have tested buoyantBoussinesqSimpleFoam running laminar in OpenFOAM-dev and OpenFOAM-3.0.x without problems. So the issue is already fixed in OpenFOAM-dev and OpenFOAM-3.0.x and there is nothing more to do.

Issue History

Date Modified Username Field Change
2016-01-08 11:14 GreatTuna New Issue
2016-01-08 11:18 henry Note Added: 0005819
2016-01-08 11:18 henry Status new => resolved
2016-01-08 11:18 henry Resolution open => no change required
2016-01-08 11:18 henry Assigned To => henry
2016-02-16 15:28 GreatTuna Note Added: 0005951
2016-02-16 15:28 GreatTuna Status resolved => feedback
2016-02-16 15:28 GreatTuna Resolution no change required => reopened
2016-02-16 15:29 GreatTuna Note Edited: 0005951 View Revisions
2016-02-16 16:10 henry Note Added: 0005952
2016-02-16 16:10 henry Status feedback => resolved
2016-02-16 16:10 henry Fixed in Version => 3.0.x
2016-02-16 16:10 henry Resolution reopened => fixed
2016-02-16 17:13 GreatTuna Note Added: 0005953
2016-02-16 17:13 GreatTuna Status resolved => feedback
2016-02-16 17:13 GreatTuna Resolution fixed => reopened
2016-02-16 17:14 GreatTuna Note Added: 0005954
2016-02-16 17:14 GreatTuna Status feedback => assigned
2016-02-16 17:39 henry Note Added: 0005955
2016-02-16 17:40 henry Status assigned => resolved
2016-02-16 17:40 henry Resolution reopened => fixed
2016-03-11 11:44 administrator Category 3.0.1 => (No Category)