View Issue Details

IDProjectCategoryView StatusLast Update
0001955OpenFOAM[All Projects] Bugpublic2015-12-17 10:06
ReporterfeymarkAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Versiondev 
Fixed in Version 
Summary0001955: Commit "v2f: Added support for fvOptions" introduced a bug in RAS turbulence model v2f
DescriptionCommit "v2f: Added support for fvOptions" introduced a bug in RAS turbulence model v2f. When choosing v2f model the following error is found.

--> FOAM FATAL ERROR:
incompatible dimensions for operation
    [f[0 -2 -1 0 0 0 0] ] + [f[0 0 -2 0 0 0 0] ]

The problem is solved by changing the line,

      + fvOptions(alpha, rho, f_)

to

      + fvOptions(f_)
TagsNo tags attached.

Activities

feymark

2015-12-17 01:41

reporter   ~0005781

My bad using fvOptions(f_) will not solve the problem. One possibility however is to use,
      + fvOptions(alpha, rho/this->nu(), f_)

henry

2015-12-17 08:39

manager   ~0005782

Thanks for reporting this problem.

I don't think your suggestion using nu() is appropriate for the f-equation, in fact it is not clear what form an fvOptions source should take as f is not a transported dynamic field. For the moment I plan to remove the fvOptions source from the f-equation until there is a specific need which will show what the form should be.

feymark

2015-12-17 09:26

reporter   ~0005783

Thank you for the quick response.

henry

2015-12-17 10:06

manager   ~0005784

Resolved by commit 3ad87864a3aeba4a6c481ed71eb1230618fa7aae

Issue History

Date Modified Username Field Change
2015-12-17 00:11 feymark New Issue
2015-12-17 01:41 feymark Note Added: 0005781
2015-12-17 08:39 henry Note Added: 0005782
2015-12-17 09:26 feymark Note Added: 0005783
2015-12-17 10:06 henry Note Added: 0005784
2015-12-17 10:06 henry Status new => resolved
2015-12-17 10:06 henry Resolution open => fixed
2015-12-17 10:06 henry Assigned To => henry