View Issue Details

IDProjectCategoryView StatusLast Update
0001886OpenFOAM[All Projects] Bugpublic2015-10-31 17:57
ReporterwyldckatAssigned Tohenry 
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Version 
Summary0001886: Make/options for subsetMesh is including unused folders and library
DescriptionTechnically there is no problem, this is just a clean up of dependencies that currently aren't being used:

  - The "cellSelection" folder no longer exists.

  - The depending on "dynamicMesh" doesn't seem operational at the moment. There are no dependencies to it in the ".dep" file. And linking to this library seems unnecessary.

In the "Additional Information " section is shown the differences that show the changes made in the attached file "options", meant to replace the one at "applications/utilities/mesh/manipulation/subsetMesh/Make".

Steps To Reproduce
diff --git a/applications/utilities/mesh/manipulation/subsetMesh/Make/options b/applications/utilities/mesh/manipulation/subsetMesh/Make/options
index 52519d4..969020c 100644
--- a/applications/utilities/mesh/manipulation/subsetMesh/Make/options
+++ b/applications/utilities/mesh/manipulation/subsetMesh/Make/options
@@ -1,11 +1,8 @@
 EXE_INC = \
- -IcellSelection \
     -I$(LIB_SRC)/finiteVolume/lnInclude \
- -I$(LIB_SRC)/dynamicMesh/lnInclude \
     -I$(LIB_SRC)/meshTools/lnInclude
 
 EXE_LIBS = \
     -lfiniteVolume \
- -ldynamicMesh \
     -lmeshTools \
     -lgenericPatchFields
Additional InformationI was curious how this appeared in the first place and since the history repository is now public, I took a look at how it appeared and was later partially removed:

  - How it appeared: https://github.com/OpenCFD/OpenFOAM-history/commit/cbf30e0fbc02f197edd1b748def201ae64c3a740

  - How it almost disappeared again: https://github.com/OpenCFD/OpenFOAM-history/commit/e2f9873aebd07d62ac1207f319fb9be0df73c1c0
TagsNo tags attached.

Activities

wyldckat

2015-10-31 17:49

updater  

options (169 bytes)
EXE_INC = \
    -I$(LIB_SRC)/finiteVolume/lnInclude \
    -I$(LIB_SRC)/meshTools/lnInclude

EXE_LIBS = \
    -lfiniteVolume \
    -lmeshTools \
    -lgenericPatchFields
options (169 bytes)

henry

2015-10-31 17:56

manager   ~0005533

Resolved by commit 2ac29110299040816e5a27c4aae84377ad89f3e9

Issue History

Date Modified Username Field Change
2015-10-31 17:49 wyldckat New Issue
2015-10-31 17:49 wyldckat Status new => assigned
2015-10-31 17:49 wyldckat Assigned To => henry
2015-10-31 17:49 wyldckat File Added: options
2015-10-31 17:56 henry Note Added: 0005533
2015-10-31 17:56 henry Status assigned => resolved
2015-10-31 17:56 henry Resolution open => fixed