View Issue Details

IDProjectCategoryView StatusLast Update
0001850OpenFOAM[All Projects] Bugpublic2015-09-09 19:46
ReporterhannesAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0001850: dynOneEqEddy LES model causes NaN in first time step
DescriptionIn the first time step after starting a LES simulation with the dynOneEqEddy model, the residuals in U equation are displayed as NaN.
The issue holds for OpenFOAM-2.4.x.
Steps To ReproduceThe issue occurs spuriously, depending on the prescribed initial conditions.
Additional InformationThe problem could be traced into the constructor of the dynOneEqEddy class. It was caused by negative values in the field KK with very small magnitude. While these were already clipped in the "correct"-method (line 153), this clipping procedure was not done in the constructor (where the same expression was repeated).

The following modification fixes the issue:

@@ -133,7 +133,8 @@ dynOneEqEddy::dynOneEqEddy
 {
     bound(k_, kMin_);
 
- const volScalarField KK(0.5*(filter_(magSqr(U)) - magSqr(filter_(U))));
+ volScalarField KK(0.5*(filter_(magSqr(U)) - magSqr(filter_(U))));
+ KK.max(dimensionedScalar("small", KK.dimensions(), SMALL));
     updateSubGridScaleFields(symm(fvc::grad(U)), KK);
 
     printCoeffs();
TagsNo tags attached.

Activities

henry

2015-09-09 19:46

manager   ~0005347

Resolved in OpenFOAM-2.4.x by commit e040f431bac28ce3aac3eff31c918a8c98135231

Note that this bug is not present in OpenFOAM-dev which has an improved implementation.

Issue History

Date Modified Username Field Change
2015-09-08 07:56 hannes New Issue
2015-09-09 19:46 henry Note Added: 0005347
2015-09-09 19:46 henry Status new => resolved
2015-09-09 19:46 henry Resolution open => fixed
2015-09-09 19:46 henry Assigned To => henry