View Issue Details

IDProjectCategoryView StatusLast Update
0001836OpenFOAM[All Projects] Bugpublic2016-08-16 15:36
Reporteruser1222Assigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Versiondev 
Summary0001836: --> FOAM FATAL ERROR: Particle lost across cyclicAMI & --> FOAM FATAL ERROR: cell, tetFace and tetPt search failure at position
DescriptionHello,

Regarding these two posts which are described as resolved.

1) http://www.openfoam.org/mantisbt/view.php?id=1694
2) http://www.openfoam.org/mantisbt/view.php?id=1341

I have tried to run the attached case with icoUncoupledKinematicParcelDyMFoam but it always crashes at Time=0.0113s with the first error. ie Particle lost across cyclicAMI ..

When you try to load the last timestep (0.01s) with paraFoam and choose kinematicCloud - lagrangian then paraFoam crashes with the second error ie cell, tetFace and tetPt search failure at position ...

This occurs with OpenFOAM 2.4.0, OpenFOAM 2.3.x and OpenFOAM 2.4.x.

This occurs even if binary output is selected.


Steps To Reproduceunzip attached file and run blockMesh, then run icoUncoupledKinematicParcelDyMFoam to Time=0.0113s for first error

paraFoam .... Apply
Click kinematicCloud - lagrangian under Mesh Parts ... Apply
Additional InformationAppears to be related to this
http://www.cfd-online.com/Forums/openfoam/126792-error-during-reconstructing-lagarangian-fields.html#post519560
& this
http://www.openfoam.org/mantisbt/view.php?id=1461
TagsNo tags attached.

Activities

user1222

2015-08-24 17:00

 

conceptTest.tar.gz (4,968 bytes)

shildenbrand

2016-08-09 11:53

reporter   ~0006661

We also encounter very often errors of type:


"FOAM FATAL ERROR: cell, tetFace and tetPt search failure at position" - and we tried using binary format and ascii format with high precision. This error shows up when restarting a case or when trying to reconstruct from a parallel computation.

This error is related to #1461, #1341, #1097 -- in my case there's no AMI involved.

I have not yet created an own testcase but the existing ones in #1341 bring up this error (after restart at t=0.001s). There is also another testcase I found on cfd-online (http://www.cfd-online.com/Forums/openfoam/126792-error-during-reconstructing-lagarangian-fields.html, post #10), which I attached here.

shildenbrand

2016-08-09 11:58

reporter  

dsmcKn0d1_2.tgz (1,715,469 bytes)

wyldckat

2016-08-09 12:43

updater   ~0006662

Last edited: 2016-08-09 12:45

View 2 revisions

@shildenbrand: Which OpenFOAM versions are you using? Because the original report refers to 2.4.0 (edit: 2.3.x and 2.4.x) and there have been a lot of changes since then.

shildenbrand

2016-08-09 12:58

reporter   ~0006663

I was trying 4.x and dev

henry

2016-08-16 12:06

manager   ~0006675

Please test the latest updates to the lagrangian library in OpenFOAM-dev which should resolve the AMI and restart issues:

commit e60bfc7d021a5e259eb2bac7c804f0067bfbfb58
Author: Henry Weller <http://cfd.direct>
Date: Tue Aug 16 11:33:27 2016 +0100

    AMIInterpolation: Make tracking across AMI more robust
    
    If a suitable face an the receiving side of the AMI cannot be found the
    particle is marked for deletion.

commit 2673f4e2dd569918fcaeee1acc44950bb9470c45
Author: Henry Weller <http://cfd.direct>
Date: Tue Aug 16 11:32:27 2016 +0100

    lagrangian: Delete lost particles on restart
    Warning messages are generated for each particle deleted

shildenbrand

2016-08-16 14:39

reporter   ~0006679

The testcases posted here run without error after this commit as well as the postprocessing (reconstructPar and particleTracks) in our project simulations.

Within these four tests the error has not occured again.
Thanks for the commit.

Issue History

Date Modified Username Field Change
2015-08-24 17:00 user1222 New Issue
2015-08-24 17:00 user1222 File Added: conceptTest.tar.gz
2015-08-24 17:04 henry Priority immediate => normal
2015-08-24 17:40 wyldckat Additional Information Updated View Revisions
2016-08-09 11:53 shildenbrand Note Added: 0006661
2016-08-09 11:58 shildenbrand File Added: dsmcKn0d1_2.tgz
2016-08-09 12:43 wyldckat Note Added: 0006662
2016-08-09 12:45 wyldckat Note Edited: 0006662 View Revisions
2016-08-09 12:58 shildenbrand Note Added: 0006663
2016-08-16 12:06 henry Note Added: 0006675
2016-08-16 14:39 shildenbrand Note Added: 0006679
2016-08-16 15:35 henry Status new => resolved
2016-08-16 15:35 henry Fixed in Version => dev
2016-08-16 15:35 henry Resolution open => fixed
2016-08-16 15:35 henry Assigned To => henry