View Issue Details

IDProjectCategoryView StatusLast Update
0001832OpenFOAM[All Projects] Bugpublic2015-08-19 11:44
ReportermaHeinAssigned Tohenry 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version8
Product Version 
Fixed in Version 
Summary0001832: noise documentation incorrect
DescriptionThe documentation for the noise tool states, that the noiseDict should look like the following:

csvFileData
{
    fileName "pressureData"
    nHeaderLine 1;
    refColumn 0;
    componentColumns (1);
    separator " ";
}

However, this does not work and abort with the following error message:

--> FOAM FATAL IO ERROR:
keyword pressureData is undefined in dictionary "/disk401/home/heinri8/Projekt/Validation/tandemCylinder/simulation/backward/system/noiseDict"


The correct dict looks like:

pressureDat
{
    fileName "pressureData";
    nHeaderLine 0;
    refColumn 0;
    componentColumns (2);
    mergeSeparators true;
    separator " ";
}

Could you correct the documentation in the noise.C file?
TagsNo tags attached.

Activities

maHein

2015-08-18 14:25

reporter   ~0005260

My mistake, the correct dict looks like:

pressureData
{
    fileName "pressureData";
    nHeaderLine 0;
    refColumn 0;
    componentColumns (2);
    mergeSeparators true;
    separator " ";
}

wyldckat

2015-08-18 18:42

updater  

noise_and_CSV.patch (1,762 bytes)
diff --git a/applications/utilities/postProcessing/noise/noise.C b/applications/utilities/postProcessing/noise/noise.C
index 79a5521..28c3b4a 100644
--- a/applications/utilities/postProcessing/noise/noise.C
+++ b/applications/utilities/postProcessing/noise/noise.C
@@ -42,13 +42,16 @@ Description
     fU          10000;
     graphFormat raw;
 
-    csvFileData
+    pressureData
     {
         fileName        "pressureData"
-        nHeaderLine     1;
-        refColumn       0;
-        componentColumns (1);
-        separator       " ";
+        nHeaderLine         1;          // number of header lines
+        refColumn           0;          // reference column index
+        componentColumns    (1);        // component column indices
+        separator           " ";        // optional (defaults to ",")
+        mergeSeparators     no;         // merge multiple separators
+        outOfBounds         clamp;      // optional out-of-bounds handling
+        interpolationScheme linear;     // optional interpolation scheme
     }
     \endverbatim
 
diff --git a/src/OpenFOAM/primitives/functions/DataEntry/CSV/CSV.H b/src/OpenFOAM/primitives/functions/DataEntry/CSV/CSV.H
index 78476ad..fa048f9 100644
--- a/src/OpenFOAM/primitives/functions/DataEntry/CSV/CSV.H
+++ b/src/OpenFOAM/primitives/functions/DataEntry/CSV/CSV.H
@@ -32,7 +32,7 @@ Description
         <entryName> csvFile;
         <entryName>Coeffs
         {
-            nHeaderLine         4;
+            nHeaderLine         4;          // number of header lines
             refColumn           0;          // reference column index
             componentColumns    (1 2 3);    // component column indices
             separator           ",";        // optional (defaults to ",")
noise_and_CSV.patch (1,762 bytes)

wyldckat

2015-08-18 18:42

updater  

noise.C (5,866 bytes)

wyldckat

2015-08-18 18:43

updater  

CSV.H (5,956 bytes)

wyldckat

2015-08-18 18:45

updater   ~0005265

Last edited: 2015-08-18 18:53

View 2 revisions

Attached 3 files:

 - "noise_and_CSV.patch" - includes the changes provided in the following 2 files.

 - "noise.C" file for updating "applications/utilities/postProcessing/noise/noise.C", which includes the updated description based on the original "noise.C" file and the "CSV.H" file.

 - "CSV.H" file for updating "src/OpenFOAM/primitives/functions/DataEntry/CSV/CSV.H", only because the "nHeaderLine" keyword didn't have a description on the header.

edit: all 3 referring to 2.4.x.

henry

2015-08-19 11:43

manager   ~0005271

Thanks for the patch but the files were more useful to merge the changes into OpenFOAM-dev.

Resolved by
commit a0fd6061860ab3b5e6ce9d3b7f9d57b9b1a13f45 in OpenFOAM-2.4.x
commit 2828d82cba8f68a2e4819c4e593cbb452952e87a in OpenFOAM-dev

Issue History

Date Modified Username Field Change
2015-08-18 14:24 maHein New Issue
2015-08-18 14:25 maHein Note Added: 0005260
2015-08-18 18:42 wyldckat File Added: noise_and_CSV.patch
2015-08-18 18:42 wyldckat File Added: noise.C
2015-08-18 18:43 wyldckat File Added: CSV.H
2015-08-18 18:45 wyldckat Note Added: 0005265
2015-08-18 18:53 wyldckat Note Edited: 0005265 View Revisions
2015-08-19 11:43 henry Note Added: 0005271
2015-08-19 11:43 henry Status new => resolved
2015-08-19 11:43 henry Resolution open => fixed
2015-08-19 11:43 henry Assigned To => henry