View Issue Details

IDProjectCategoryView StatusLast Update
0001829OpenFOAM[All Projects] Bugpublic2015-09-02 14:33
Reporteruser1216Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformGNU/LinuxOSDebianOS Version3.16.7-ck
Product Version 
Fixed in Version 
Summary0001829: pressure jumps occur, when restarting rotating mesh simulation with interPhaseChangeDyMFoam
DescriptionThe problem occurs in both 2.3.x and 2.4.x.

I started a cavitating propeller simulation using interPhaseChangeDyMFoam with cyclicAMI BCs and the rotating mesh motion defined in the constant/dynamicMesh dictionary. The simulation runs well and gives good qualitative results when started from time "0".

The problem occurs when I restart the simulation from a later saved time step. I need to reduce the time step to do so, but if I do, the simulation is able to at least start running again. But just after the first simulated time step, there is then a total change of the pressure field, which gives me new maximum and minimum values of pressure, which are 2 to 3 orders of magnitude higher than they were before the restart! The influence is present in the whole fluid domain and basically destroys any pre-converged results. I checked whether the propeller position is correct at restart and it sure is.

I tested this for my own propeller simulation, as well as for the tutorial case of interPhaseChangeDyMFoam.


Thank you very much for your help.
Steps To ReproduceStart a propeller simulation (e.g. interPhaseChangeDyMFoam propeller tutorial) with the rotatingMotion and cyclicAMIs. Wait until you see some sort of cavitation and save a time step where you restart the simulation from. Write the very next time step after restart and have a look at the pressure field, which should be totally disturbed in the whole domain.
Additional Information1. Read about the correctPhi bug in an older release. Tried to comment this out, but results were the same (crappy).

2. When I let the propeller rotate for some time, then restart with a small time step the pressure jumps occur whether I start with interPhaseChangeDyMFoam (with mesh rotation) or with interPhaseChangeFoam (without further mesh rotation) despite the propeller position being correct.

3. When starting a simulation without mesh rotation (but the same setup including the AMIs) using interPhaseChangeFoam, then restart the simulation at some time, this error does NOT occur, despite cavitation being there as well and so on. The only difference to the case where the error occurs is that there was rotation BEFORE the restart. This is why my guess is now that this has to do something with the rotatingMotion.

4. I simulated lots of cavitating simulations before with interPhaseChange(DyM)Foam and the restarts worked nicely all the time. But these simulations were all with stationary meshes...

5. The problem occurs in both 2.3.x and 2.4.x.
TagsNo tags attached.

Activities

user1216

2015-08-17 07:46

 

user1216

2015-08-17 07:47

 

user1216

2015-08-17 07:48

  ~0005254

First image is after restart, second image is initial domain before restart.

Issue History

Date Modified Username Field Change
2015-08-17 07:46 user1216 New Issue
2015-08-17 07:46 user1216 File Added: stackOverflow_propellerError_02.png
2015-08-17 07:47 user1216 File Added: stackOverflow_propellerError_01.png
2015-08-17 07:48 user1216 Note Added: 0005254