View Issue Details

IDProjectCategoryView StatusLast Update
0001801OpenFOAM[All Projects] Bugpublic2015-07-30 12:46
ReporterAlgisDAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSDebianOS Version7
Product Version 
Fixed in Version 
Summary0001801: Specification of case directory for mesh blockMesh
Description1) blockMesh incorrectly interpretates alternate case directory defined by the argument '-case' in command line. For example:

~/OpenFOAM/user-2.4.0/run/tutorials/incompressible/icoFoam$ blockMesh -case cavity
======================================= Error message start:
--> FOAM FATAL ERROR:
Cannot open mesh description file
    "./cavity/./cavity/constant/polyMesh/blockMeshDict"

    From function blockMesh
    in file blockMeshApp.C at line 149.

FOAM exiting
======================================= Error message end

Note: icoFoam '-case' interpretates correctly.
Steps To Reproducecd $FOAM_RUN/tutorials/incompressible/icoFoam/cavity
cd ..
blockMesh -case cavity
TagsNo tags attached.

Relationships

duplicate of 0001773 resolvedhenry "-case" option does not work for blockMesh anymore 

Activities

wyldckat

2015-07-29 14:05

updater   ~0005143

Last edited: 2015-07-29 14:05

View 2 revisions

This is already fixed in 2.4.x, see issue #1773.

The commit with the fix is this one: https://github.com/OpenFOAM/OpenFOAM-2.4.x/commit/13440e9d176a43705442c30292f0bd1a2e063ec5

Issue History

Date Modified Username Field Change
2015-07-29 09:35 AlgisD New Issue
2015-07-29 14:03 wyldckat Relationship added duplicate of 0001773
2015-07-29 14:05 wyldckat Note Added: 0005143
2015-07-29 14:05 wyldckat Note Edited: 0005143 View Revisions
2015-07-30 12:45 wyldckat Status new => closed
2015-07-30 12:46 wyldckat Resolution open => duplicate
2015-07-30 12:46 wyldckat Fixed in Version => 2.4.x