View Issue Details

IDProjectCategoryView StatusLast Update
0001756OpenFOAM[All Projects] Bugpublic2015-10-23 12:43
Reporteruser4Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOpenSuSEOS Version12.3
Product Version 
Fixed in Version 
Summary0001756: mergeMeshes does not respect -noFunctionObjects command line option
DescriptionmergeMeshes does a runTime++ which executes the functionObjects. Normally you can suppress this with -noFunctionObjects but this does not work in mergeMeshes since this command line option does not get passed through.

Solution1: in createTimes.H construct Time with the 'enableFunctionObjects' argument correctly set.

Solution2: do like mapFields/createTimes.H
Steps To ReproduceRun attached case with

mergeMeshes ../twoBlock -masterRegion domain0 ../twoBlock -addRegion domain1 -noFunctionObjects
TagsNo tags attached.

Activities

user4

2015-06-22 11:56

 

twoBlock_20150622.tgz (7,234 bytes)

henry

2015-10-23 12:43

manager   ~0005484

Resolved in OpenFOAM-dev by commit 86f10cda394fc9a19a7fe7316c19abf5fd75baf9

Issue History

Date Modified Username Field Change
2015-06-22 11:56 user4 New Issue
2015-06-22 11:56 user4 File Added: twoBlock_20150622.tgz
2015-10-23 12:43 henry Note Added: 0005484
2015-10-23 12:43 henry Status new => resolved
2015-10-23 12:43 henry Resolution open => fixed
2015-10-23 12:43 henry Assigned To => henry