View Issue Details

IDProjectCategoryView StatusLast Update
0001734ThirdParty[All Projects] Bugpublic2015-06-09 12:07
ReporterpetebachantAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Version 
Fixed in Version 
Summary0001734: ParaView will not build on Ubuntu GNOME 15.04
DescriptionI'm not sure if this happens on plain Ubuntu, but ParaView will not build from the 2.4.x repo on Ubuntu GNOME 15.04. I am getting this result:

[ 14%] Building CXX object VTK/Rendering/OpenGL/CMakeFiles/vtkRenderingOpenGL.dir/vtkXOpenGLRenderWindow.cxx.o
In file included from /usr/include/GL/glx.h:333:0,
                 from /home/pete/OpenFOAM/ThirdParty-2.4.x/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx:31:
/usr/include/GL/glxext.h:480:143: error: ‘GLintptr’ has not been declared
 typedef void ( *PFNGLXCOPYBUFFERSUBDATANVPROC) (Display *dpy, GLXContext readCtx, GLXContext writeCtx, GLenum readTarget, GLenum writeTarget, GLintptr readOffset, GLintptr writeOffset, GLsizeiptr size);
Steps To ReproduceFollow the instructions for Git repository installation. All is successful until executing "makeParaView4".
TagsNo tags attached.

Activities

henry

2015-06-08 08:41

manager   ~0004896

I had the same problem on recent Ubuntu releases. There is some discussion abouth this issue on the Internet and it is not completely clear if the issue is with system header files or with VTK. Anyway, I am currently using the following change to avoid the problem:

*** Ubuntu 14.10 and higher
    There is an issue in the GL libraries requiring a change to the
    vtkXOpenGLRenderWindow.cxx file in ParaView:
    Uncomment line 30

    #define GLX_GLXEXT_LEGACY

    This is required for both 32bit and 64bit.

I also needed this change to build on OpenSuSE Tumbleweed.

I am not sure if this changes can be applied for all OSs or if it should only be applied for systems which need it. If it is generally applicable I will make the change in the source-pack.

petebachant

2015-06-09 06:15

reporter   ~0004900

That works. Thanks!

Issue History

Date Modified Username Field Change
2015-06-08 03:37 petebachant New Issue
2015-06-08 08:41 henry Note Added: 0004896
2015-06-09 06:15 petebachant Note Added: 0004900
2015-06-09 12:07 henry Status new => resolved
2015-06-09 12:07 henry Resolution open => fixed
2015-06-09 12:07 henry Assigned To => henry