View Issue Details

IDProjectCategoryView StatusLast Update
0001727OpenFOAM[All Projects] Bugpublic2015-06-02 09:10
ReporteralexeymAssigned Tohenry 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0001727: dnsFoam includes readPISOControls.H yet does not use any variables from the file
DescriptionOn line 60 of dnsFoam.C there is a statement

#include "readPISOControls.H"

On line 86 loop that looks like PISO starts (it even has comment PISO loop), yet the loop does not use any PISO controls:

for (int corr=1; corr<=1; corr++)
{
    ...
}

Should include statement be removed?
Steps To Reproduce1. Go to $FOAM_APP/solvers/DNS/dnsFoam
2. Open dnsFoam.C
TagsNo tags attached.

Activities

henry

2015-06-02 09:10

manager   ~0004872

Resolved by commit 1c58abec87ad0251ece3266f83802f1fad32d1d6

Note that in OpenFOAM-dev all the CFD applications now use the solver control classes.

Issue History

Date Modified Username Field Change
2015-06-02 06:37 alexeym New Issue
2015-06-02 09:10 henry Note Added: 0004872
2015-06-02 09:10 henry Status new => resolved
2015-06-02 09:10 henry Resolution open => fixed
2015-06-02 09:10 henry Assigned To => henry