View Issue Details

IDProjectCategoryView StatusLast Update
0001581OpenFOAM[All Projects] Bugpublic2015-03-29 19:56
Reporteruser1080Assigned Tohenry 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0001581: Fatal IO error using TableFile type BC with pimpleFoam
DescriptionI have two cases which are exactly same except for the geometry, one is cylinder and the other is a box. One runs without errors and the other crashes due to an IO error. I can confirm that there are no apparent differences between the two cases. I spent a lot of time to make sure.

The issue is with the format of the table file

A detailed explanation is given here with neat formatting which is not possible here. Check it out http://www.cfd-online.com/Forums/openfoam-solving/149213-time-varying-velocity-inlet-boundary-conditions-using-tablefile-h.html
Steps To ReproduceHere is the git repository to the case file https://github.com/pruthvi1991/OpenFOAM-bug-reporting/tree/master/TableFile_error

Run the case named crashing case. This one crashes for me all the time

Run the case named successful case. This case runs without issue.

Use the Allrun.sh scripts to run a case.
Additional InformationMake sure that you change the path to dataFile for topAndBottom, fixedInlet patches located in 0.org/include/topAndBottom,fixedInlet

Here is the link to that file for one of the cases. https://github.com/pruthvi1991/OpenFOAM-bug-reporting/blob/master/TableFile_error/crashing_run/inertial_0.2Mach_NACA0012_1e-3_6procs/0.org/include/frontBackTopBottomPatches

The box case takes a little while to mesh.
TagsNo tags attached.

Activities

user1080

2015-03-27 18:30

  ~0004500

I think this error is being caused because of using the same datafile for two boundaries. Looks like its necessary to have a file for every boundary with a time varying velocity. I was able to fix the error using a file for each and every boundary.

wyldckat

2015-03-29 13:26

updater   ~0004533

The first issue is what you've already stated here: http://www.cfd-online.com/Forums/openfoam-solving/149213-time-varying-velocity-inlet-boundary-conditions-using-tablefile-h.html#post538784
Namely that the file "src/OpenFOAM/primitives/functions/DataEntry/TableFile/TableFile.H" has a wrong description, because this:

    \verbatim
        (
            0.0 (1 2 3)
            1.0 (4 5 6)
        );
    \endverbatim

is wrong and it should be:

    \verbatim
        (
            (0.0 (1 2 3))
            (1.0 (4 5 6))
        );
    \endverbatim


I still need to check the second issue, namely if there is a problem with opening the same file twice.

wyldckat

2015-03-29 13:41

updater   ~0004534

@pruthvi1991: The second problem, namely the original report, doesn't exist. You had included the same file for the boundary settings "topAndBottom" for both the "U" and "p" fields. Therefore, it was a user error, not a bug.


Nonetheless, the description in the header file still needs to be updated, as indicated in the previous comment.

henry

2015-03-29 19:56

manager   ~0004541

Thanks for the bug-report and correction.
Resolved by commit 3b4870d706d20ddec4bddd9e725e96e76e19ca9c

Issue History

Date Modified Username Field Change
2015-03-22 21:56 user1080 New Issue
2015-03-24 00:17 liuhuafei Issue cloned: 0001584
2015-03-27 18:30 user1080 Note Added: 0004500
2015-03-29 13:26 wyldckat Note Added: 0004533
2015-03-29 13:41 wyldckat Note Added: 0004534
2015-03-29 19:56 henry Note Added: 0004541
2015-03-29 19:56 henry Status new => resolved
2015-03-29 19:56 henry Resolution open => fixed
2015-03-29 19:56 henry Assigned To => henry