View Issue Details

IDProjectCategoryView StatusLast Update
0001575OpenFOAM[All Projects] Bugpublic2015-03-20 17:03
Reporteruser1103Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformUnixOSOtherOS Version(please specify)
Product Version 
Fixed in Version 
Summary0001575: Regex issue in tutorials/multiphase/twoPhaseEulerFoam/RAS/bubbleColumn/
DescriptionI am getting the following exception when running icoFoam against $FOAM_RUN/tutorials/multiphase/twoPhaseEulerFoam/RAS/bubbleColumn/ :

   --> FOAM FATAL ERROR:
   Failed to compile regular expression 'div\(\(\(\(alpha.**thermo:rho.*\)*nuEff.*\)*dev2\(T\(grad\(U.*\)\)\)\)\)'
   repetition-operator operand invalid

       From function regExp::set(const char*)
       in file regExp.C at line 93.

   FOAM exiting

There appears to be an extra asterisk or one that isn't escaped, in system/fvSchemes
TagsNo tags attached.

Activities

henry

2015-03-19 08:09

manager   ~0004149

I am unable to reproduce this problem on GNU/Linux (OpenSuSE 13.1) so there seems to be a difference in the regex library you are using. Which OS are you running on?

Try escaping the second * in the "alpha.**", i.e." alpha.*\*"

If this works OK I will change all the occurrences in the tutorials

user1103

2015-03-20 16:54

  ~0004166

This was on MacOS X and another user on the platform suggested that he worked around the issue by escaping the second star. I haven't been able to check this on a Linux based host to compare, as of yet.

henry

2015-03-20 17:03

manager   ~0004168

Resolved by commit f783759ca1f5fe8f88089a375a35b08f4d65674d in OpenFOAM-dev

Issue History

Date Modified Username Field Change
2015-03-19 03:03 user1103 New Issue
2015-03-19 08:09 henry Note Added: 0004149
2015-03-20 16:54 user1103 Note Added: 0004166
2015-03-20 17:03 henry Note Added: 0004168
2015-03-20 17:03 henry Status new => resolved
2015-03-20 17:03 henry Resolution open => fixed
2015-03-20 17:03 henry Assigned To => henry
2015-03-24 00:17 liuhuafei Issue cloned: 0001597