View Issue Details

IDProjectCategoryView StatusLast Update
0000155OpenFOAM[All Projects] Bugpublic2011-03-06 22:49
Reporteruser146Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000155: explicit laplacian calculation involving Tensor do not compile
Description
I tried to program an explicit laplacian calculation involving a dimensioned tensor and it don't compile:

dimensionedTensor Ma (....)
dimensionedTensor Mb (....)

solve
(
    fvm::laplacian(Ma,pa)+fvc::laplacian(Mb,pb)
);

The problem comes from the explicit laplacian calculation. According to my own test the problem is only present when Mb is a Tensor. there is no problem if Mb is a scalar.

Obviously, I can workaround the main issue by decomposing the laplacian with tensor into a sum of 9 laplacians with scalar... but it is not elegant.

I also note that fvc::flux() do not take into account for the tensor..

Regards,
Cyp
TagsNo tags attached.

Activities

henry

2011-03-06 22:49

manager   ~0000277

Thanks for the bug report, this is resolved by
commit 6c20862effe98d70c854f60c1bb37d99bd25f287

Issue History

Date Modified Username Field Change
2011-03-04 11:08 user146 New Issue
2011-03-06 22:49 henry Note Added: 0000277
2011-03-06 22:49 henry Status new => resolved
2011-03-06 22:49 henry Resolution open => fixed
2011-03-06 22:49 henry Assigned To => henry