View Issue Details

IDProjectCategoryView StatusLast Update
0001547OpenFOAM[All Projects] Bugpublic2015-02-25 23:33
ReporterwyldckatAssigned Tohenry 
PrioritylowSeveritytextReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0001547: In regards to Issue #1450: "decomposePar with scotch breaks for cyclicACMI patch..."
DescriptionSince the issue was closed before I managed to answer, this bug report acts a bit as an addendum:

1. There was a typo in the patch that I had attached on that report, in the line of "WarningIn", where it states "cyclicAMIPolyPatch", it should instead be "cyclicACMIPolyPatch" (i.e. missing the "C" in "ACMI"). This was unfortunately also inherited in the commit that was pushed to 2.3.x.

2. Using the same tutorial case "incompressible/pimpleDyMFoam/oscillatingInletACMI2D", with 96 subdomains decomposed with either scotch or hierarchical "(2 48 1)", there were no occurrences of a partial mismatch of sizes. In other words, "tgtMask_" was always either 0 or of equal size.

3. Nonetheless, since this case has a very simple mesh, it will require some deeper investigation into the source code to ascertain whether such a situation of non-zero lists not having the same size is even possible. Either way, the implemented hack does seem to cover most of the potential problems.
TagsNo tags attached.

Activities

henry

2015-02-25 23:33

manager   ~0003915

Resolved by commit commit f219e26d11b6124a0a9532c69a910ff90d6474e9

I think the hack is sufficent until the cyclicACMIPolyPatch is rewritten but if you come across a situation in which it fails please reopen this report.

Issue History

Date Modified Username Field Change
2015-02-25 22:46 wyldckat New Issue
2015-02-25 23:33 henry Note Added: 0003915
2015-02-25 23:33 henry Status new => resolved
2015-02-25 23:33 henry Resolution open => fixed
2015-02-25 23:33 henry Assigned To => henry