View Issue Details

IDProjectCategoryView StatusLast Update
0001534OpenFOAM[All Projects] Bugpublic2015-02-16 22:12
ReporterwyldckatAssigned Tohenry 
PrioritylowSeveritytextReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0001534: surfaceCheck: option "-blockMesh" gives hard to see/parse output
DescriptionWhen using the "-blockMesh" option in "surfaceCheck", it's a bit hard to visually see where the output will end for the suggested "blockMeshDict" contents.
And it's harder to have automatic parsing... well, unless the detection is based on finding "patches\n();".

Attached is both the patch "surfaceCheck_block_format.patch" and the modified file "applications/utilities/surface/surfaceCheck/surfaceCheck.C".

I didn't suggest using "IOobject::writeDivider" and "writeEndDivider", because it made things a bit confusing.
TagsNo tags attached.

Activities

wyldckat

2015-02-16 19:40

updater  

surfaceCheck_block_format.patch (900 bytes)
diff --git a/applications/utilities/surface/surfaceCheck/surfaceCheck.C b/applications/utilities/surface/surfaceCheck/surfaceCheck.C
index 8116ab0..756b56c 100644
--- a/applications/utilities/surface/surfaceCheck/surfaceCheck.C
+++ b/applications/utilities/surface/surfaceCheck/surfaceCheck.C
@@ -223,8 +223,9 @@ int main(int argc, char *argv[])
     {
         pointField cornerPts(boundBox(surf.points(), false).points());
 
-        Info<<"// blockMeshDict info" << nl
-            <<"vertices\n(" << nl;
+        Info<<"// blockMeshDict info" << nl << nl;
+
+        Info<<"vertices\n(" << nl;
         forAll(cornerPts, ptI)
         {
             Info << "    " << cornerPts[ptI] << nl;
@@ -239,6 +240,8 @@ int main(int argc, char *argv[])
 
         Info<<"edges\n();" << nl
             <<"patches\n();" << endl;
+
+        Info<< nl << "// end blockMeshDict info" << nl << endl;
     }
 
 

wyldckat

2015-02-16 19:40

updater  

surfaceCheck.C (21,519 bytes)

henry

2015-02-16 22:12

manager   ~0003807

Thanks for the update
Resolved by commit 8d28dc8ad4596b048ca6c0d9803c0cc517acbf0b

Issue History

Date Modified Username Field Change
2015-02-16 19:40 wyldckat New Issue
2015-02-16 19:40 wyldckat File Added: surfaceCheck_block_format.patch
2015-02-16 19:40 wyldckat File Added: surfaceCheck.C
2015-02-16 22:12 henry Note Added: 0003807
2015-02-16 22:12 henry Status new => resolved
2015-02-16 22:12 henry Resolution open => fixed
2015-02-16 22:12 henry Assigned To => henry