View Issue Details

IDProjectCategoryView StatusLast Update
0001530OpenFOAM[All Projects] Bugpublic2017-03-06 20:21
Reporteruser26Assigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
PlatformGNU/LinuxOSOpenSuSEOS Version13.2
Product Version 
Fixed in Version 
Summary0001530: fvMeshDistribute does not handle pointFIelds
DescriptionThe fvMeshDistribute class, which is intended for load-balancing, does not re-distribute pointFields. This is vital for dynamic mesh problems (like six-DOF) which rely on pointMesh functionality to specify boundary conditions.
Steps To ReproduceTake any dynamic mesh case with pointFields (and optionally, changing mesh topology), and invoke fvMeshDistribute.
TagsNo tags attached.

Relationships

related to 0002086 closedhenry redistributePar doesn't distribute point*Field 
related to 0002487 resolvedhenry Error with sixDoFRigidBodyDisplacementPointPatchVectorField in parallel 

Activities

wyldckat

2015-02-15 18:34

updater   ~0003787

This seems conceptually similar to issue #1140: http://www.openfoam.org/mantisbt/view.php?id=1140

Any chance you can provide a test case?

user26

2015-02-15 19:27

  ~0003789

No - it's not related. That issue deals with mapping pointFields, and seems to fail even in serial. This is parallel-specific because of re-distribution.

This really doesn't need a test case - it's not a bug but rather, missing functionality. And it's pretty obvious from the fvMeshDistribute sources that only volFields/surfaceFields are mapped, but not pointFields.

henry

2015-10-22 10:03

manager   ~0005461

Feature request requiring funding or code contribution.

Issue History

Date Modified Username Field Change
2015-02-15 17:56 user26 New Issue
2015-02-15 18:34 wyldckat Note Added: 0003787
2015-02-15 19:27 user26 Note Added: 0003789
2015-10-22 10:03 henry Note Added: 0005461
2015-10-22 10:03 henry Status new => closed
2015-10-22 10:03 henry Assigned To => henry
2015-10-22 10:03 henry Resolution open => suspended
2016-05-09 23:10 wyldckat Relationship added related to 0002086
2017-03-06 20:21 wyldckat Relationship added related to 0002487