View Issue Details

IDProjectCategoryView StatusLast Update
0001524OpenFOAM[All Projects] Bugpublic2015-03-05 17:52
ReporterprojectionistAssigned Tohenry 
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.10
Product Version 
Fixed in Version 
Summary0001524: refineWallLayer destroys cellZones
DescriptionWhen I create a mesh with a cellZone and later refine the cells next to a patch, my cellZone gets disrupted.

I posted before/after images there: http://www.cfd-online.com/Forums/openfoam-meshing-utilities/148505-refinewalllayer-breaks-cellzones.html
Steps To ReproduceCreate a cellZone which contains cells at a boundary patch
Call refineWallLayer for this very boundary patch
Watch the cellZone
TagsNo tags attached.

Activities

projectionist

2015-02-13 16:14

reporter  

wyldckat

2015-02-14 15:24

updater   ~0003764

Greetings Gerhard,

Any chance you can provide a test case for this?
I think I know how to solve this, since it's a zone and something very similar was implemented in "decomposePar" and "reconstructPar" in OpenFOAM 2.3.0. But better yet, this is something that "snappyHexMesh" already is able to do!

Therefore, if you can provide the test case, it'll be easier to implement and test this feature request.

Best regards,
Bruno

projectionist

2015-02-16 08:55

reporter  

pipeMesh.tar.gz (2,830 bytes)

projectionist

2015-02-16 08:58

reporter   ~0003794

I added a case. It's a simple cylindrical mesh. All cells belong to a cellZone called "zone" (I am very creative at making up names). The cell zone definition is part of blockMeshDict, thus I can not redo the creation of the cellZone, as it would be the case, if I used topoSet or a similar tool.

Run 'blockMesh' and afterwards 'refineWallLayer walls 0.5'

Open ParaView and watch the fate of the zone.

henry

2015-03-05 17:51

manager   ~0003968

Resolved by commit 4e8fad3a72a756cade7fa201f8215725518f509d

Issue History

Date Modified Username Field Change
2015-02-13 16:14 projectionist New Issue
2015-02-13 16:14 projectionist File Added: cellZone_afterRefinement.png
2015-02-14 15:24 wyldckat Note Added: 0003764
2015-02-16 08:55 projectionist File Added: pipeMesh.tar.gz
2015-02-16 08:58 projectionist Note Added: 0003794
2015-03-05 17:51 henry Note Added: 0003968
2015-03-05 17:51 henry Status new => resolved
2015-03-05 17:51 henry Resolution open => fixed
2015-03-05 17:51 henry Assigned To => henry