View Issue Details

IDProjectCategoryView StatusLast Update
0001494OpenFOAM[All Projects] Bugpublic2016-02-03 21:03
ReportermatteoLAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformcentosOSOtherOS Version(please specify)
Product Version 
Fixed in Version 
Summary0001494: mirrorMesh does not work in parallel
DescriptionHello,
it seems mirrorMesh does not work in parallel even if it has the -parallel flag.

When I run it in parallel I get:
Create time

--> FOAM Warning :
    From function Time::operator++()
    in file db/Time/Time.C at line 1055
    Increased the timePrecision from 7 to 100 to distinguish between timeNames at time 0
--> FOAM Warning :
    From function Time::operator++()
    in file db/Time/Time.C at line 1064
    Current time name 0 is the old as the previous one 0
    This might result in overwriting old results.
[node291.cluster.racing.lc:77034] 7 more processes have sent help message help-mpi-btl-sm.txt / knem fail open
[node291.cluster.racing.lc:77034] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages
Mirroring points. Old points: 190025 New points: 380050
Mirroring faces. Old faces: 998867--> FOAM Warning :
    From function mirrorFvMesh::mirrorFvMesh(const IOobject&)
    in file mirrorFvMesh.C at line 158
    Found coupled patch procBoundary0to1
    Mirroring faces on coupled patches destroys the ordering. This might be fixed by running a dummy createPatch afterwards.
--> FOAM Warning :
    From function mirrorFvMesh::mirrorFvMesh(const IOobject&)
    in file mirrorFvMesh.C at line 158
    Found coupled patch procBoundary0to8
    Mirroring faces on coupled patches destroys the ordering. This might be fixed by running a dummy createPatch afterwards.
--> FOAM Warning :
    From function mirrorFvMesh::mirrorFvMesh(const IOobject&)
    in file mirrorFvMesh.C at line 158
    Found coupled patch procBoundary0to32
    Mirroring faces on coupled patches destroys the ordering. This might be fixed by running a dummy createPatch afterwards.
--> FOAM Warning :
    From function mirrorFvMesh::mirrorFvMesh(const IOobject&)
    in file mirrorFvMesh.C at line 158
    Found coupled patch procBoundary0to33
    Mirroring faces on coupled patches destroys the ordering. This might be fixed by running a dummy createPatch afterwards.
--> FOAM Warning :
    From function mirrorFvMesh::mirrorFvMesh(const IOobject&)
    in file mirrorFvMesh.C at line 158
    Found coupled patch procBoundary0to40
    Mirroring faces on coupled patches destroys the ordering. This might be fixed by running a dummy createPatch afterwards.
 New faces: 1997734
Mirroring patches. Old patches: 11 New patches: 8
Mirroring cells. Old cells: 407326 New cells: 814652
Mirroring cell shapes.

Creating new mesh
[3] [5]
[5]
[5] --> FOAM FATAL ERROR:
[5] Unknown polyPatch type processor for patch procBoundary5to4

Valid polyPatch types are :

18
(
cyclic
cyclicACMI
cyclicAMI
cyclicSlip
empty
genericPatch
mappedPatch
mappedWall
mappedWallVariableThickness
nonuniformTransformCyclic
oldCyclic
patch
regionCoupled
regionCoupledWall
symmetry
symmetryPlane
wall
wedge
)
[5]
[5]
[5] From function polyPatch::New(const word&, const word&, const label, const label, const label, const polyBoundaryMesh&)
[5] in file meshes/polyMesh/polyPatches/polyPatch/polyPatchNew.C at line 58.
[5]
FOAM parallel run exiting
[5]

[4]
[4]
[4] --> FOAM FATAL ERROR:
[4] Unknown polyPatch type processor for patch procBoundary4to3





Steps To ReproduceTake a decomposed mesh and run mirrormesh in parallel.
TagsNo tags attached.

Activities

user4

2015-03-11 12:13

  ~0004081

This is a known limitation and seems easy enough to fix. The problem is that the patches for the mirrored mesh get created from components instead of being cloned from the old mesh. We will look into this.

wyldckat

2015-11-29 21:00

updater  

mirrorFvMesh.C (12,238 bytes)

wyldckat

2015-11-29 21:02

updater  

elipsekkLOmega.tar.gz (4,698 bytes)

wyldckat

2015-11-29 21:08

updater   ~0005688

Attached are the following files:

  - elipsekkLOmega.tar.gz - It's a modified case of the tutorial "incompressible/pimpleFoam/elipsekkLOmega", adapted for testing the mesh generation with mirrorMesh in serial and in parallel. It uses it twice, so it's both the only and the almost perfect test case.

  - mirrorFvMesh.C - updated file for replacing "applications/utilities/mesh/manipulation/mirrorMesh/mirrorFvMesh.C". This is directly based on Mattijs fix that is present in commit 769abd353ca2e324b513b7c51524d12c481bc1d3 in the OpenFOAM-history repository: https://github.com/OpenCFD/OpenFOAM-history/commit/769abd353ca2e324b513b7c51524d12c481bc1d3

The attached file "mirrorFvMesh.C" is already adapted to OpenFOAM-dev, and possibly can also be used in 3.0.x.

The test was done in serial with the attached case in OpenFOAM 3.0.x without the test fix, and then in OpenFOAM-dev with the fix in serial and parallel.
The resulting "log.checkMesh" files are nearly identical of 3.0.x serial vs dev parallel.
Therefore it does seem that this fixes the reported issue and has been tested with at least this test case.


@matteoL: Any chance you still have your case that lead to the initial report, so that you can test the attached fix as well?

henry

2015-11-29 21:43

manager   ~0005690

Thanks Bruno, I have applied the change to OpenFOAM-dev for evaluation:
commit a24eec402c39fbc69dd546fffa4c0d4ea6aff182

henry

2016-02-03 21:03

manager   ~0005904

No problems with the patch have been reported so I assume this is now resolved.

Thanks for the fix Bruno.

Issue History

Date Modified Username Field Change
2015-01-20 10:29 matteoL New Issue
2015-03-11 12:13 user4 Note Added: 0004081
2015-03-24 00:17 liuhuafei Issue cloned: 0001622
2015-11-29 21:00 wyldckat File Added: mirrorFvMesh.C
2015-11-29 21:02 wyldckat File Added: elipsekkLOmega.tar.gz
2015-11-29 21:08 wyldckat Note Added: 0005688
2015-11-29 21:43 henry Note Added: 0005690
2016-02-03 21:03 henry Note Added: 0005904
2016-02-03 21:03 henry Status new => resolved
2016-02-03 21:03 henry Resolution open => fixed
2016-02-03 21:03 henry Assigned To => henry