View Issue Details

IDProjectCategoryView StatusLast Update
0001468OpenFOAM[All Projects] Bugpublic2015-05-01 00:49
Reporteruser1056Assigned Tohenry 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformDesktop and ClusterOSLinux Mint / SUSEOS Version17 / Enterprise
Product Version 
Fixed in Version 
Summary0001468: Something wrong in the CrankNicolson ddt scheme (2.3.x)
DescriptionWhen running LES calculation on 2.3.x with CrankNicolson ddt scheme,
maximum courant number gradually increases and finally calculation blows.

I cannot see the problem with backward ddt scheme or CrankNicolson in "2.2.x".
So, I can guess any changes between 2.2.x and 2.3.x causes the problem.

In addition, I have been faced with the problem since 2.3.0 released.
So, It might not be caused by recent commitment.
Steps To ReproduceRunning tutorial case (pisoFoam/pitzDaily) with:
ddtSchemes
{
    default CrankNicolson 1;
}

Initial residuals of each velocity component remains higher (near 0.9) and courant number starts weaving.

Finally, calculation will stop at Time=0.02656 (in my case).
TagsNo tags attached.

Activities

henry

2014-12-28 12:52

manager   ~0003363

Thanks for the report.

In OpenFOAM-2.3.? I changed ddtCorr to handle mesh-motion in a more general way, accurately including the effects of face rotation as well as translation. However, it was not clear that this approach needed the Crank-Nicolson corrections and tests showed that the Euler ddtCorr handling was sufficient for the Crank-Nicolson scheme. But these tests were done using a small amount of off-centering:

    default CrankNicolson 0.9;

which has been found necessary in order to stabilize this scheme for complex flows, providing similar accuracy and stability as the backward scheme. I have now run tests without off-centering as you are running and also find that for cases where this is stable in OpenFOAM-2.2.x it is not stable in OpenFOAM-2.3.x, unless the Crank-Nicolson corrections to ddtCorr are reinstated. I have now pushed this change to OpenFOAM-2.3.x.

Resolved by commit 9a79633f0723bd714aa25f3eec21e4d90623ee90

Issue History

Date Modified Username Field Change
2014-12-25 10:18 user1056 New Issue
2014-12-28 12:52 henry Note Added: 0003363
2014-12-28 12:52 henry Status new => resolved
2014-12-28 12:52 henry Resolution open => fixed
2014-12-28 12:52 henry Assigned To => henry