View Issue Details

IDProjectCategoryView StatusLast Update
0001460OpenFOAM[All Projects] Bugpublic2014-12-13 23:03
Reporteruser969Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04 LTS
Product Version 
Fixed in Version 
Summary0001460: Error during compilation of "coalCombustion" library
DescriptionWhen building OpenFOAM-2.3.x, error during the build occurs. The "coalCombustion" library is affected with the following error message:

In file included from coalParcel/makeCoalParcelSubmodels.C:27:0:
lnInclude/makeCoalParcelSurfaceReactionModels.H:33:37: fatal error: COxidationIntrinsicRate.H: No such file or directory
 #include "COxidationIntrinsicRate.H"
                                     ^
compilation terminated.
make: *** [Make/linux64GccDPOpt/makeCoalParcelSubmodels.o] Error 1

The problem is that the "missing" file exists in the source directory, and I presume that some config file messed up.
Steps To ReproduceBuild OpenFOAM-2.3.x with default options.
Additional InformationI've attached my build log.
TagsNo tags attached.

Activities

user969

2014-12-12 10:28

 

make.log.tar.gz (5,871 bytes)

wyldckat

2014-12-13 20:41

updater   ~0003313

Greetings,

This is one of those really curious issues that occur "once in a blue moon". What happened is that the error you got occurred because a specific symbolic link either failed to be created or was deleted. Try running the following commands:

    cd $WM_PROJECT_DIR
    find src -name COxidationIntrinsicRate.H | xargs ls -l

This should show you something like this:

    lrwxrwxrwx 1 ofuser ofuser 83 Dec 13 19:20 src/lagrangian/coalCombustion/lnInclude/COxidationIntrinsicRate.H -> ../submodels/surfaceReactionModel/COxidationIntrinsicRate/COxidationIntrinsicRate.H

    -rw-rw-r-- 1 ofuser ofuser 5024 Dec 13 18:46 src/lagrangian/coalCombustion/submodels/surfaceReactionModel/COxidationIntrinsicRate/COxidationIntrinsicRate.H

In theory, you're not getting the first occurrence, because link file "coalCombustion/lnInclude/COxidationIntrinsicRate.H" is damaged (i.e. deleted or not created or misdirected). The "->" characters indicate that the symbolic link is in fact pointing to the second file.


As to why this happened? No clue. This sort of scenario usually occurs after a "git pull" brings a new file or deleted another... but these two files have existed since the beginning of OpenFOAM 2.3.x, which is why I referred to this case as occurring "once in a blue moon".


Now, as for the solution, it's similar to bug #626 and the solution can possibly be something like this:

    wclean libso $FOAM_SRC/lagrangian/coalCombustion
    cd $WM_PROJECT_DIR
    ./Allwmake > make2.log 2>&1

Please do give feedback on whether this solves the issue or not, so that the bug can be closed by the developers.


Best regards,
Bruno

user969

2014-12-13 22:45

  ~0003314

Dear Bruno,

Your fix really solved this issue.

I presume that this kind of problems can be avoided during the build process by rebuilding symbolic links before compilation process (a wild guess but maybe it could help).

Thank you for your help.
Best regards.
Budo

Issue History

Date Modified Username Field Change
2014-12-12 10:28 user969 New Issue
2014-12-12 10:28 user969 File Added: make.log.tar.gz
2014-12-13 20:41 wyldckat Note Added: 0003313
2014-12-13 22:45 user969 Note Added: 0003314
2014-12-13 23:02 henry Status new => resolved
2014-12-13 23:02 henry Resolution open => fixed
2014-12-13 23:02 henry Assigned To => henry