View Issue Details

IDProjectCategoryView StatusLast Update
0001443OpenFOAM[All Projects] Bugpublic2015-03-05 18:55
Reporteruser1033Assigned Tohenry 
PrioritynoneSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04
Product Version 
Fixed in Version 
Summary0001443: blockMesh creating extra patches near axis of wedge
DescriptionA nozzle is modelled. The model has an axisymmetric geometry, so it uses the wedge-type geometry. For a certain set of coordinates, 4 to 6 extra faces are generated near the axis in the throat region. In paraview, this looks like the hex cells are divided into triangles.
If the coordinates of the nozzle are changed ever so slightly, the problem does not appear.
Steps To Reproduce- Unpack blockMesh_files.tar.gz
- use blockMesh on blockMeshDict_bug
--> 6 defaultFaces patches will be created near the axis in the throat region
- use blockMesh on blockMeshDict_working (the only difference is a change in the coordinates at the throat region)
--> no defaultFaces are created.
Additional InformationPerformed on Ubuntu VirtualBox (native OS is Windows)
OF 2.3.0
TagsblockMesh

Activities

user1033

2014-11-13 13:21

 

blockMesh_files.tar.gz (1,009 bytes)

henry

2015-03-05 18:55

manager   ~0003970

Resolved by commit 390055bdf092763122793c62a8fe858be80b1c1e

Issue History

Date Modified Username Field Change
2014-11-13 13:21 user1033 New Issue
2014-11-13 13:21 user1033 File Added: blockMesh_files.tar.gz
2015-02-14 21:11 wyldckat Tag Attached: blockMesh
2015-03-05 18:55 henry Note Added: 0003970
2015-03-05 18:55 henry Status new => resolved
2015-03-05 18:55 henry Resolution open => fixed
2015-03-05 18:55 henry Assigned To => henry