View Issue Details

IDProjectCategoryView StatusLast Update
0001432OpenFOAM[All Projects] Bugpublic2015-01-28 09:04
ReporteralbertopAssigned Tohenry 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSuseOS Version13.2
Product Version 
Fixed in Version 
Summary0001432: Improved compile settings with Intel compilers
DescriptionBy default, the Intel ICC (v. 13) compiler

- does not catch division by zero and other problems with floating point operations
- uses fast1 floating point operations, which may lead to problems in some conditions

This can be solved by adding the options:

-fp-trap=common -fp-model precise

to the C++ compiler rules in

wmake/rules/linuxIcc
wmake/rules/linux64Icc

Regards,
Alberto
TagsNo tags attached.

Activities

wyldckat

2015-01-27 20:40

updater   ~0003592

Well this is certainly annoying...

- Intel is currently marketing the 15.* series, with no "free for non-commercial use" version available yet

- There is no longer a download link for 14.0.1 for Linux, which is the supported version of for OpenFOAM 2.3.*

- I can't find an online document indicating if these options for ICC are still available and/or default for 14.* and 15.*


@Alberto: Any chance you have ICC 14 or 15, to check if these options are still applicable?

henry

2015-01-27 20:55

manager   ~0003593

As you say, currently we are unable to test OpenFOAM with the Intel compiler. If Intel release version 15.* free for us to test we will do so and add the options Alberto suggests if they are still needed.

albertop

2015-01-28 03:45

reporter   ~0003601

The options I indicated are still needed with ICC 15.x.

I had to introduce them because we have licenses for Intel compilers on our cluster, and when a 'nan' is encountered, cases keep running.

Only -fp-trap=common is needed for exception trapping. The floating point model is for accuracy, and probably less important.

Unfortunately, I am not sure if/when there will be a 'free for non-commercial use' license. If you need to test anything, however, I probably can do it on our machines.

henry

2015-01-28 09:03

manager   ~0003604

Resolved by commit 873e0c8d58acf0729d25d9328765e8c9b2bc4023

Issue History

Date Modified Username Field Change
2014-10-31 17:47 albertop New Issue
2015-01-27 20:40 wyldckat Note Added: 0003592
2015-01-27 20:55 henry Note Added: 0003593
2015-01-28 03:45 albertop Note Added: 0003601
2015-01-28 09:03 henry Note Added: 0003604
2015-01-28 09:03 henry Status new => resolved
2015-01-28 09:03 henry Resolution open => fixed
2015-01-28 09:03 henry Assigned To => henry