View Issue Details

IDProjectCategoryView StatusLast Update
0001415OpenFOAM[All Projects] Bugpublic2014-12-28 17:00
ReporterwyldckatAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0001415: updateCoeffs() in "fanFvPatchField.C" is using "scalar" implementation
DescriptionIn the file "$FOAM_SRC/finiteVolume/fields/fvPatchFields/derived/fan/fanFvPatchField.C", the method "updateCoeffs()" has this call to one of the inherited parent method of the same name:

  fixedJumpFvPatchField<scalar>::updateCoeffs();

the potential problem that I noticed is that the class "fanFvPatchField" is still in template form and it doesn't seem to make much sense for the generic template method to call a specific implementation "scalar" of the template class "fixedJumpFvPatchField".
Additional InformationI can only guess that this has worked fine so far, because only the scalar implementation is the one mostly likely to be used. The other possibility is that the method "updateCoeffs()" is identical in any implementation of the class "fixedJumpFvPatchField".
TagsNo tags attached.

Activities

henry

2014-12-28 17:00

manager   ~0003368

Resolved by commit b3abea74ddf800f29d9dd06edec1698d154e4b2f

Issue History

Date Modified Username Field Change
2014-10-15 16:28 wyldckat New Issue
2014-12-28 17:00 henry Note Added: 0003368
2014-12-28 17:00 henry Status new => resolved
2014-12-28 17:00 henry Resolution open => fixed
2014-12-28 17:00 henry Assigned To => henry