View Issue Details

IDProjectCategoryView StatusLast Update
0001398OpenFOAM[All Projects] Bugpublic2015-03-02 19:15
Reporteruser998Assigned Tohenry 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version13.10
Product Version 
Fixed in Version 
Summary0001398: compressibleInterFoam: Different results between in parallel and in serial computing
DescriptionHello,

I'm using compressibleInterFoam for my project of supersonic jet and liquid flow (compressible 2-phase flow).

Before using this solver for my project, I made simple test case. Test case is "Supersonic flow over a forward-face step". I ran simulation for rhoPimpleFoam and compressilbeInterFoam both in parallel(4 processors) and serial computing. So, I turn on transonic in the FVsolution to capture supersonic flow.

For rhoPimplFoam, simulation results are the same both in parallel and serial.
However, for compressibleInterFoam, simulation results are different between in serial and parallel. Discontinuities of pressure distribution are observed at the interface between sub-domains.

I tested for openfoam 2.2.2 and openfoam 2.3.0, both of them have same problem.
And this problem happens the computational domain of my project.

I've attached case files and results at 2(s) for rhoPimpleFoam and compressibleInterFoam both in parallel and serial computing.
TagscompressibleInterFoam, parallel, Parallel computing

Activities

user998

2014-09-12 17:21

 

forwardStepCIFparallel.zip (236,348 bytes)

user998

2014-09-12 17:34

  ~0003233

In the case of simulation using compressibleInterFoam, I turn off second fluid flow feature to make simulation conditions for test case. In that case, I think that this solver is the same as compressible 1-phase flow solver.

dhora

2014-11-03 20:48

reporter   ~0003277

Using fvc::div(phid1, p_rgh) instead of fvm::div(phid1, p_rgh) and fvc::div(phid2, p_rgh) instead of fvm::div(phid2, p_rgh) seems to fix the problem in 2.3.x

user998

2015-03-02 17:13

  ~0003944

I tried to use fvc::div(phid1, p_rgh) instead of fvm::div(phid1, p_rgh) and fvc::div(phid2, p_rgh) instead of fvm::div(phid2, p_rgh). This seems to fix the problem of pressure discontinuity at the interface between sub-domains. However, the results is not in agreement with other test cases(rhoPimpleFoam or sonicFoam).

henry

2015-03-02 18:18

manager   ~0003945

Using fvc::div(phid?, p_rgh) rather than fvm::div(phid?, p_rgh) is equivalent to using the sub-sonic algorithm, have you tried this?

The solution will indeed be different to using rhoPimpleFoam or sonicFoam because it is based on a compressible correction to div(U) to support the very large phase density differences typical of multiphase systems.

henry

2015-03-02 19:15

manager   ~0003946

I just tested the case with OpenFOAM-2.3.x and OpenFOAM-dev and see on features associated with the decomposition -- the solutions look identical to those from serial running.

Issue History

Date Modified Username Field Change
2014-09-12 17:21 user998 New Issue
2014-09-12 17:21 user998 File Added: forwardStepCIFparallel.zip
2014-09-12 17:25 user998 Tag Attached: compressibleInterFoam
2014-09-12 17:25 user998 Tag Attached: Parallel computing
2014-09-12 17:25 user998 Tag Detached: Parallel computing
2014-09-12 17:26 user998 Tag Attached: Parallel computing
2014-09-12 17:26 user998 Tag Attached: parallel
2014-09-12 17:34 user998 Note Added: 0003233
2014-11-03 20:48 dhora Note Added: 0003277
2015-03-02 17:13 user998 Note Added: 0003944
2015-03-02 18:18 henry Note Added: 0003945
2015-03-02 19:15 henry Note Added: 0003946
2015-03-02 19:15 henry Status new => resolved
2015-03-02 19:15 henry Resolution open => fixed
2015-03-02 19:15 henry Assigned To => henry