View Issue Details

IDProjectCategoryView StatusLast Update
0001295OpenFOAM[All Projects] Bugpublic2014-12-18 12:53
ReporterdkxlsAssigned Tohenry 
PriorityhighSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformLinux x86_64OSopenSUSEOS Version12.2
Product Version 
Fixed in Version 
Summary0001295: [SprayParcel]: Stripped parcel mass should be reduced due to evaporation
DescriptionThis was correctly implemented in the old dieselSpray classes:
https://github.com/OpenFOAM/OpenFOAM-2.0.x/blob/master/src/lagrangian/dieselSpray/parcel/parcel.C#L284

A patch to correct this is attached.
Tagsbreakup, Lagrangian, spray

Activities

dkxls

2014-05-16 18:12

reporter  

0001-lagrangian-SprayParcel-Reduce-the-stripped-parcel-ma.patch (916 bytes)
diff --git a/src/lagrangian/spray/parcels/Templates/SprayParcel/SprayParcel.C b/src/lagrangian/spray/parcels/Templates/SprayParcel/SprayParcel.C
index da615ae..6857e75 100644
--- a/src/lagrangian/spray/parcels/Templates/SprayParcel/SprayParcel.C
+++ b/src/lagrangian/spray/parcels/Templates/SprayParcel/SprayParcel.C
@@ -96,10 +96,15 @@ void Foam::SprayParcel<ParcelType>::calc
     scalar rho0 = composition.liquids().rho(pc0, T0, X0);
     this->rho() = rho0;

+    const scalar mass0 = this->mass();
     ParcelType::calc(td, dt, cellI);

     if (td.keepParticle)
     {
+        // Reduce the stripped parcel mass due to evaporation (assuming the
+        // number of particles stayed the same)
+        this->ms() -= this->ms()*(mass0 - this->mass())/mass0;
+
         // update Cp, diameter and density due to change in temperature
         // and/or composition
         scalar T1 = this->T();
--
1.7.10.4

dkxls

2014-12-18 10:33

reporter   ~0003330

This bug is still present in 2.3.1!

henry

2014-12-18 12:53

manager   ~0003335

Thanks for the bug-report and patch

Resolved by commit 2d4b6577342c2dbbeb8aa5c796bd53e6d7263912

Issue History

Date Modified Username Field Change
2014-05-16 18:12 dkxls New Issue
2014-05-16 18:12 dkxls File Added: 0001-lagrangian-SprayParcel-Reduce-the-stripped-parcel-ma.patch
2014-06-11 16:10 dkxls Tag Attached: breakup
2014-06-11 16:10 dkxls Tag Attached: Lagrangian
2014-06-11 16:10 dkxls Tag Attached: spray
2014-12-18 10:33 dkxls Note Added: 0003330
2014-12-18 12:53 henry Note Added: 0003335
2014-12-18 12:53 henry Status new => resolved
2014-12-18 12:53 henry Resolution open => fixed
2014-12-18 12:53 henry Assigned To => henry