View Issue Details

IDProjectCategoryView StatusLast Update
0001293OpenFOAM[All Projects] Bugpublic2020-11-21 20:30
ReporterdhoraAssigned Tohenry 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionsuspended 
Product Version 
Fixed in Version 
Summary0001293: Improvement of moving (rotating) mesh cases
DescriptionDear developers

I'm using a SIMPLE based solver (transientSimpleDyMFoam) together with OpenFOAM-2.2.x for simulations of centrifugal pumps and discovered that the rotation of the mesh leads to a quite strong distortion of the pressure and velocity fields (e.g. torque increased by 18% after the first corrector loop in one of our cases). I tried to reduce this distortion by rotating the corresponding part of the velocity field with the mesh before the momentum equations are being solved. The idea was that such a modification could simplify the computation of the final solution if we have more or less steady conditions in the rotating domain. The results are quite interesting: reduced distortion of the solution (torque only increased by 4% after the first corrector loop), lower residuals, less iterations and a reduced computation time. The source code (not perfect but working) and a presentation with results of a 2D mixer and a single channel pump can be found here:

http://www.extend-project.de/user-forums/extend-groups/14-special-interest-group-on-turbomachinery-group-forum/658-improvement-of-transientsimpledymfoam

The modification seems to be a clear improvement and could also be useful for pimpleDyMFoam simulations in OpenFOAM-2.3.

Best regards
David
Additional InformationThe monitoring of the values had to be implemented in the solver. A more general approach would still be desirable (http://www.openfoam.org/mantisbt/view.php?id=641).

The movingWall boundary condition provides inaccurate results for walls in rotating domains. It's not a burning issue but you can see it if you calculate the relative velocities in the rotating domain. It would require a new boundary condition but could be solved easily.

TagsNo tags attached.

Activities

henry

2020-11-21 20:30

manager   ~0011720

Requires funding for a more general solution.

Issue History

Date Modified Username Field Change
2014-05-13 17:08 dhora New Issue
2020-11-21 20:30 henry Assigned To => henry
2020-11-21 20:30 henry Status new => closed
2020-11-21 20:30 henry Resolution open => suspended
2020-11-21 20:30 henry Note Added: 0011720