View Issue Details

IDProjectCategoryView StatusLast Update
0001274OpenFOAM[All Projects] Bugpublic2015-02-05 09:17
Reporteruser914Assigned Tohenry 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0001274: Unable to Work on OpenFOAm in Ubuntu 14.04
DescriptionI had been using OpenFOAM in my Ubuntu 13.10 system and i got an update for Ubuntu 14.04 after which i am unable to work on OpenFOAM. Even i tried installing OPenFOAM again but i am unable to install again. Please help me to solve this issue and work on Ubuntu.
Thank You
TagsNo tags attached.

Activities

wyldckat

2014-04-25 17:04

updater   ~0003029

Disclaimer: I'm just a fellow bug reporter, but experienced in installing OpenFOAM.

I'm guessing you followed the instructions from here: http://openfoam.org/download/ubuntu.php

I tried to use the Deb packages from the "saucy" repository and the error message from apt-get is this:

  The following information may help to resolve the situation:

  The following packages have unmet dependencies:
   openfoam230 : Depends: libboost-thread1.53.0 but it is not installable
                 Depends: libopenmpi1.3 but it is not installable
  E: Unable to correct problems, you have held broken packages.



Until the official OpenFOAM Deb packages are released for Ubuntu 14.04, you'll have to follow the instructions for building from source code: http://openfoam.org/download/source.php


In addition, I strongly suggest that in the future you wait at least a month before upgrading to the next major Ubuntu version, because Ubuntu's new versions are somewhat known to have issues in the first 20-30 days.

henry

2015-02-05 09:17

manager   ~0003681

Ubuntu 14.04 and 14.10 are available for OpenFOAM-2.3.1

Issue History

Date Modified Username Field Change
2014-04-25 12:30 user914 New Issue
2014-04-25 17:04 wyldckat Note Added: 0003029
2015-02-05 09:17 henry Note Added: 0003681
2015-02-05 09:17 henry Status new => resolved
2015-02-05 09:17 henry Resolution open => fixed
2015-02-05 09:17 henry Assigned To => henry