View Issue Details

IDProjectCategoryView StatusLast Update
0001233ThirdParty[All Projects] Bugpublic2015-01-18 19:17
ReporterwyldckatAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0001233: Building ParaView 4.1.0 with MPI and the custom build Open-MPI 1.6.5 will fail
DescriptionIf the options the following options in the "ThirdParty-2.3.*/Allwmake" script are present:

  --disable-mpi-cxx

  --disable-c++

and if the respective "WM_MPLIB" shell environment variable is defined to use either one of the custom MPI libraries, then running "makeParaView4 -mpi" will fail, because the MPI C++ library will be missing.
TagsNo tags attached.

Activities

wyldckat

2015-01-18 10:47

updater   ~0003556

I should have been clearer. What I meant was that in the script "ThirdParty-2.3.*/Allwmake", the following options should be removed for the respective MPI toolboxes:

* Open-MPI:
  --disable-mpi-cxx

* MPICH:
  --disable-c++


If those options are not present when the custom builds are done, this means that the makeParaView* scripts will work just fine with the option "-mpi", when using the custom builds of Open-MPI and MPICH.

henry

2015-01-18 19:16

manager   ~0003559

Resolved by commit edafe1ac451f6299b20c7f59909d0e58b644ba09

Issue History

Date Modified Username Field Change
2014-03-22 11:50 wyldckat New Issue
2015-01-18 10:47 wyldckat Note Added: 0003556
2015-01-18 19:16 henry Note Added: 0003559
2015-01-18 19:16 henry Status new => resolved
2015-01-18 19:16 henry Resolution open => fixed
2015-01-18 19:16 henry Assigned To => henry