View Issue Details

IDProjectCategoryView StatusLast Update
0001209OpenFOAM[All Projects] Bugpublic2015-04-30 20:19
ReporteralbertopAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformLinuxOSopenSUSEOS Version13.1
Product Version 
Fixed in Version 
Summary0001209: Should MULES use alphaMax rather than 1 with particulate models?
DescriptionThe MULES call in twoPhaseEulerFOAM / twoPhaseSystem.C is

MULES::explicitSolve
(
   geometricOneField(),
   alpha1,
   phi_,
   alphaPhic1,
   Sp,
   Su,
   1,
   0
);

However in the previous implementation of twoPhaseEulerFoam, the bounds for alpha were set to 0 and alphaMax in the case of particulate flows, where alphaMax < 1. Shouldn't this be the case also in the new twoPhaseEulerFoam?
TagsNo tags attached.

Activities

henry

2014-03-06 23:14

manager   ~0002931

I thought about it and concluded that it wasn't clear that alphaMax is a preferable because it is a soft limit; the phase-fraction may exceed alphaMax without serious problem. If alphaMax is used for the MULES limiter upwind differencing would be used anywhere alpha exceeds alphaMax; do you think that would be a good thing?

albertop

2014-03-07 03:10

reporter   ~0002932

I see your point. Indeed some models (Schaeffer, for example) let alphaMax be a soft limit, while others consider it as a hard limit (kinetic theory, Johnson and Jackson), so it's not clear.

I asked because with models that consider it a hard limit, alpha is limited when it approaches alphaMax, to avoid divergence of the particle pressure. This in some cases leads to a phase pressure that isn't sufficient to prevent a further increase in alpha, which can become very high. If I understand it correctly, MULES should enforce alphaMax as a hard limit, and prevent this.

henry

2014-03-07 08:43

manager   ~0002935

> If I understand it correctly, MULES should enforce alphaMax as a hard limit,
> and prevent this

Yes, provided the schemes (other than convection) are bounded schemes. For example if the laplacian is corrected on a non-orthogonal mesh MULES cannot currently guarantee boundedness as it operates only on the convection flux.

Nevertheless I take your point and will change the MULES call to limit to alphaMax.

henry

2014-03-07 23:40

manager   ~0002938

Resolved by commit 97056cd4664657296e7028756edc05cdb87b0e06

Issue History

Date Modified Username Field Change
2014-03-06 22:54 albertop New Issue
2014-03-06 23:14 henry Note Added: 0002931
2014-03-07 03:10 albertop Note Added: 0002932
2014-03-07 08:43 henry Note Added: 0002935
2014-03-07 23:40 henry Note Added: 0002938
2014-03-07 23:40 henry Status new => resolved
2014-03-07 23:40 henry Resolution open => fixed
2014-03-07 23:40 henry Assigned To => henry