View Issue Details

IDProjectCategoryView StatusLast Update
0001207OpenFOAM[All Projects] Bugpublic2018-12-10 12:50
ReporterandreAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSuseOS Version13.1
Product Version 
Fixed in Version 
Summary0001207: tutorial hotBoxes: different results from OF-2.1.x to OF-2.2.x and OF-2.3.x
DescriptionDear OpenFOAM-Team,

running ./Allrun-parallel in tutorial "hotBoxes" of OF-2.1.x seems to give physically reasonable results, liquid film temperatures up to 349 K. In OF-2.2.x and OF-2.3.x the hotBoxes remain cold. Heat transfer from the hotBoxes to the liquid film do not occure. Maximum liquid film temperatures around 301 K. See attached figures.
Steps To Reproduceexecute ./Allrun-parallel in hotBoxes-tutorial of 2.2.x and 2.3.x
TagsNo tags attached.

Activities

andre

2014-03-04 17:26

reporter  

hotBoxes.png.tar.gz (517,376 bytes)

wyldckat

2015-02-01 21:58

updater   ~0003645

@andre: Any chance you can test with the latest OpenFOAM 2.3.1 or 2.3.x?

I ask this because at least in OpenFOAM 2.3.x, there was at least one change to this tutorial, namely in commit f54ea84f6dd2dc0caa7cd7ee5ab92fe2b9201fbf, which can affect the proper set-up of the case.

In addition, because this case is fairly computationally heavy (after 16714s, it has only done 1.12s of simulation in my machine, in parallel), I haven't managed to get the simulation up to the same point where you took the snapshots, namely at 2.0s.

Attached is a snapshot "snapshot_at_1.1s.png" at 1.1s, executed with a recent OpenFOAM 2.3.x and it clearly seems to have heat transfer between the surfaces of the cubes and the surrounding environment.

wyldckat

2015-02-01 21:58

updater  

snapshot_at_1.1s.png (176,353 bytes)
snapshot_at_1.1s.png (176,353 bytes)

andre

2015-02-06 17:04

reporter  

andre

2015-02-06 17:04

reporter   ~0003713

@wyldckat: Thank you for looking at this issue.

Today I've done a git pull to get the latest version of OF2.3.x and ran hotBoxes in parallel.

The hotBoxes stay cold (T=300 K) till t=0.3 s, then temperature switches to T= 350 K and stay hot. Okay so far. But in some locations on the boxes the minimum temperature is around 265 K, which isn't resonable (see attached figure). The temperatures should be in the range of [300 K , 350 K].

Using OF2.1.x the minimum temperature is 298 K.

wyldckat

2015-02-07 15:05

updater   ~0003714

@andre: I didn't think 265K was very bad, since it's still very far from absolute zero :)
But indeed, -8.15 degree Celsius seems fairly low for something that is initially in the range of 26.85 and 76.85 degree Celsius.

I took a better look at the changes that occurred in the case set-up and the solver, and there is at least one particular big detail that was changed. In the file "constant/reactingCloud1Properties", the following entries are different:

 - OpenFOAM 2.1.x:
        flowRateProfile constant 0.1;
        Umag constant 3.0;

 - OpenFOAM 2.3.x:
            flowRateProfile constant 1;
            Umag constant 1;

I'm currently running the tutorial in/from 2.1.x with "Allrun-parallel" with these values from the tutorial from 2.3.x, to try and isolate the origin of the problem...

Wait... I saw just now for 0.058s that the surface film temperature is 300K on 2.3.x and 350K on 2.1.x, just as you said. This could be a mapping error between regions... I will continue to try and isolate the problem.

wyldckat

2015-02-07 15:55

updater   ~0003715

OK, the good news is that tried the tutorial "lagrangian/reactingParcelFilmFoam/cylinder" and there is something weird happening with it as well... and this tutorial is substantially smaller and quicker to test! And the error is triggered after 10-15 seconds of running the solver!

The not so good news is that I don't know yet where to look for the bug... all I know so far is that the Courant Number for the film shoots up at the time instance 0.56s, where output for each solver version at the end of this time instance is as follows:

 - OpenFOAM 2.1.x:
    time step continuity errors : sum local = 1.592753226e-11, global = -1.503420004e-14, cumulative = 8.290360465e-06
    ExecutionTime = 14.71 s ClockTime = 14 s

    Courant Number mean: 0.001221796515 max: 0.008813443181
    Film max Courant number: 0.05046019015
    deltaT = 0.02
    Time = 0.58


 - OpenFOAM 2.3.x (commit 993cd4ee1298):
    time step continuity errors : sum local = 4.982300541e-12, global = 6.56421202e-14, cumulative = 3.267407582e-06
    ExecutionTime = 11.05 s ClockTime = 11 s

    Courant Number mean: 0.001380531545 max: 0.009993486137
    Film max Courant number: 7.030132775
    deltaT = 0.001
    Time = 0.561


With any luck, this bug is the same or very related to the one originally reported here.

andre

2015-02-09 08:36

reporter   ~0003730

@wyldckat: in the hotBoxes-tutorial the boundary condition in htcConv has been changed. Could that be the cause of trouble?
In the cylinder-tutorial there is no htcConv!?

henry

2015-03-10 14:23

manager   ~0004068

I have reverted the heat-transfer modeling in thermoSingleLayer back to how it was in OpenFOAM-2.1.x and this seems to resolve the issue report. I am not convinced either approach is correct and am running some more tests. I will push something you can try by the end of the day.

henry

2015-03-10 20:02

manager   ~0004074

Thanks for checking this case against older versions, this helped debugging.

Resolved by commit 1f187d6f9e58c232a1363aafe4ffe46e6f20f876

    thermoSingleLayer: Revert q back to the working version in OpenFOAM-2.1.x
    Revert changes in tutorial to correspond to the version in OpenFOAM-2.1.x
    Resolves bug-report http

Issue History

Date Modified Username Field Change
2014-03-04 17:26 andre New Issue
2014-03-04 17:26 andre File Added: hotBoxes.png.tar.gz
2015-02-01 21:58 wyldckat Note Added: 0003645
2015-02-01 21:58 wyldckat File Added: snapshot_at_1.1s.png
2015-02-06 17:04 andre File Added: hotBoxes_2_3_x_latestGitPull.png
2015-02-06 17:04 andre Note Added: 0003713
2015-02-07 15:05 wyldckat Note Added: 0003714
2015-02-07 15:55 wyldckat Note Added: 0003715
2015-02-09 08:36 andre Note Added: 0003730
2015-03-10 14:23 henry Note Added: 0004068
2015-03-10 20:02 henry Note Added: 0004074
2015-03-10 20:02 henry Status new => resolved
2015-03-10 20:02 henry Resolution open => fixed
2015-03-10 20:02 henry Assigned To => henry
2015-03-24 00:17 liuhuafei Issue cloned: 0001623