View Issue Details

IDProjectCategoryView StatusLast Update
0001206OpenFOAM[All Projects] Bugpublic2015-07-09 07:42
Reporteruser591Assigned Touser21 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSUbuntuOS Version12.04
Product Version 
Fixed in Version 
Summary0001206: Paraview cannot load decomposed data due to duplicated entries with keyword Qr in T file
DescriptionIf case is running in parallel, chtMultiRegionSimpleFoam writes duplicated entries with keyword Qr inside compressible::turbulentTemperatureRadCoupledMixed boundary condition section (see. additional information)

In case of a single process run, there is no duplicated keywords.

Previous version (2.2) is free from this problem.

Steps To ReproduceJust run standard /tutorials/heatTransfer/chtMultiRegionSimpleFoam/multiRegionHeaterRadiation case in parallel.
Then open latest time of a decomposed case with build-in reader of ParaView.
Additional InformationParaview shows message:
"ERROR: In /home/cvd/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/VTK/IO/Geometry/vtkOpenFOAMReader.cxx, line 6467
vtkOpenFOAMReaderPrivate (0x2ae6270): Error reading line 654 of /home/cvd/OpenFOAM/OpenFOAM-2.3.0/tutorials/heatTransfer/chtMultiRegionSimpleFoam/multiRegionHeaterRadiation/processor3/1800/bottomAir/T: Found duplicated entries with keyword Qr"

The file content is:
    bottomAir_to_heater
    {
        type compressible::turbulentTemperatureRadCoupledMixed;
        refValue nonuniform 0();
        refGradient nonuniform 0();
        valueFraction nonuniform 0();
        value nonuniform 0();
        Tnbr T;
        QrNbr none;
        Qr Qr; //1st
        Qr Qr; //2nd
        thicknessLayers 0();
        kappaLayers 0();
        kappa fluidThermo;
        kappaName none;
    }
TagsNo tags attached.

Relationships

duplicate of 0001177 resolveduser21 compressible::turbulentTemperatureRadCoupledMixed creates Qr field twice 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2014-03-04 13:12 user591 New Issue
2014-03-04 14:00 user2 Relationship added duplicate of 0001177
2014-03-04 14:01 user2 Status new => resolved
2014-03-04 14:01 user2 Fixed in Version => 2.3.x
2014-03-04 14:01 user2 Resolution open => fixed
2014-03-04 14:01 user2 Assigned To => user21