View Issue Details

IDProjectCategoryView StatusLast Update
0001196OpenFOAM[All Projects] Bugpublic2014-02-28 23:45
ReporterwyldckatAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionnot fixable 
PlatformGNU/LinuxOSUbuntu | CentOSOS Version12.04 | 6.5
Product Version 
Fixed in Version 
Summary0001196: Unable to use foamyHexMesh when built with a custom built GCC 4.8.2
DescriptionThis is in reference to commit c90486054799e2c5cd03a60e127b0dde8e824def.

Following Henry's recommendation on issue #1168 - http://www.openfoam.org/mantisbt/view.php?id=1168 - I've been building OpenFOAM 2.3.x with a custom built GCC 4.8.2, following the same version numbers defined in "makeGcc48" and "etc/config/settings.sh", as well as building CGAL-4.3 with it (i.e., ran wmSET after makeGcc48).

Problem is that when running the tutorial "mesh/foamyHexMesh/flange", I get the error shown in the attached file "log.foamyHexMesh".

The problem seems to be that either one of the following:
 1. CGAL cannot be built with GCC 4.8.2.
 2. Something in "foamyHexMesh" or "libconformalVoronoiMesh" isn't right, when linking to CGAL.
 3. Something went wrong in the build process of GCC 4.8.2, although I did test in Ubuntu 12.04 and CentOS 6.5 (both in virtual machines, both x86_64).

On all builds, I've used:
 - CGAL 4.3
 - Boost 1.54.0, custom built with "makeCGAL"

I've also built on the same Ubuntu 12.04 VM and the default GCC 4.6.3 without any problems, using the same packages.


I'll try to do some more tests, namely with a more recent Ubuntu version with GCC 4.8.*, just in case it's a problem with either the build of the custom GCC or if the problem is with CGAL's source code.
Additional InformationNote: Had to hard-code the Boost version in both "makeCGAL" and "etc/config/CGAL.sh", because "ThirdParty-2.3.*/Allwmake" calls makeCGAL directly and neither one use the version settings defined in "CGAL.sh".
TagsNo tags attached.

Activities

wyldckat

2014-02-27 12:15

updater  

log.foamyHexMesh (14,006 bytes)

henry

2014-02-27 18:08

manager   ~0002913

This appears to be a problem with gcc-4.8.2 compiling CGAL.

I have tested gcc-4.7.2, 4.8.1, 4.9.0 (pre-release) and clang 3.4 and foamyHexMesh runs fine.

Issue History

Date Modified Username Field Change
2014-02-27 12:15 wyldckat New Issue
2014-02-27 12:15 wyldckat File Added: log.foamyHexMesh
2014-02-27 18:08 henry Note Added: 0002913
2014-02-27 18:08 henry Status new => closed
2014-02-27 18:08 henry Assigned To => henry
2014-02-27 18:08 henry Resolution open => not fixable