View Issue Details

IDProjectCategoryView StatusLast Update
0000115OpenFOAM[All Projects] Bugpublic2010-12-21 15:16
ReportermatteoLAssigned Touser8 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformdebianOSOtherOS Version(please specify)
Product Version 
Fixed in Version 
Summary0000115: displacementLaplacian solver with sixDofRigidBodyDisplacement BC fails in parallel.
DescriptionWhen using the sixDofRigidBodyDisplacement BC with the displacementLaplacian meshMotion solver (I am trying to simualte a floating object) in parallel, I get an error of points size mismatch:
The output looks like:
-----
Selecting motion solver: displacmentLaplacian
Selecting motion diffusion: inverseDistance
[1]
[1]
[1] - -> FOAM FATAL IO ERROR
[1] size 94 is not equal to the given value of 95
[1]
[1] file: xxx/processor1/0/pointDisplacement::BoundaryField::Hull
...

Steps To ReproduceThe tutorial test case WingMotion2D_pimleDymFoam works in parallel, while my case doesn't. I don't knwo if it is due to the fact that it is 3D, or the fact that the mesh has been imported from fluent format, or the numebr of partitions (i am using 8 now).

If I use just two partitions, the case works.
Additional InformationMy mesh has been created via ICEM, exported in fluent format, and then converted to OF with the fluent3DtoFoam utility..
TagsNo tags attached.

Activities

user8

2010-12-21 15:16

  ~0000195

There is a problem with the decomposition of point fields (i.e. pointDisplacement) in 1.7.x - this is fixed in our internal development version and will be available in the next major release. In the meantime it is possible to workaround it.

I've pushed an Allrun_parallel script for the floating object tut into 1.7.x, commit:

    b2216e5cc47e49f551dc7485ce97d7b65de5eef1

which shows the method. Decompose the mesh before copying 0.org to 0 in each processor directory, so the pointDisplacement field is not operated on by the decomposition.

Issue History

Date Modified Username Field Change
2010-12-20 14:49 matteoL New Issue
2010-12-20 14:59 user8 Assigned To => user8
2010-12-20 14:59 user8 Status new => assigned
2010-12-21 15:16 user8 Note Added: 0000195
2010-12-21 15:16 user8 Status assigned => resolved
2010-12-21 15:16 user8 Fixed in Version => 1.7.x
2010-12-21 15:16 user8 Resolution open => fixed