View Issue Details

IDProjectCategoryView StatusLast Update
0000109OpenFOAM[All Projects] Bugpublic2016-02-03 21:40
Reporteruser101Assigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformUnixOSRedHat Enterprise LinuxOS Version5
Product Version 
Fixed in Version 
Summary0000109: mergePatchPairs does not work in a 1x1xN 1D geometry
DescriptionIf I build a 1D geometry using two hex blocks and merge the patches that consist of coincident points, the file const/polyMesh/boundaries will contain an entry for the master merged patch. The solvers will then want a boundary condition for that patch.

For details, including the blockMeshDict file, see this post: http://www.cfd-online.com/Forums/openfoam/83108-bc-internal-patch-laplacefoam.html#post287563

and also the other posts on this thread.

The problem is removed when using a 2x1, or 2x2 mesh in the ignorable direction.
Steps To Reproduce> blockMeshDict
> laplacianFoam
Additional InformationThe attached archive has all the files necessary to reproduce the problem
(except for the fixed mesh size in the ignorable direction)
TagsNo tags attached.

Activities

user101

2010-12-15 21:00

 

1D-problem.tar.gz (14,399 bytes)

henry

2015-01-29 15:43

manager   ~0003622

Have you investigated the origin of this limitation? Can you provide a patch?

henry

2016-02-03 21:40

manager   ~0005908

You did not declare which version of OpenFOAM you are using. mergePatchPairs works fine in a 1x1xN 1D geometry in OpenFOAM-dev.

Issue History

Date Modified Username Field Change
2010-12-15 21:00 user101 New Issue
2010-12-15 21:00 user101 File Added: 1D-problem.tar.gz
2015-01-29 15:43 henry Note Added: 0003622
2016-02-03 21:40 henry Note Added: 0005908
2016-02-03 21:40 henry Status new => resolved
2016-02-03 21:40 henry Resolution open => no change required
2016-02-03 21:40 henry Assigned To => henry