View Issue Details

IDProjectCategoryView StatusLast Update
0001023OpenFOAM[All Projects] Bugpublic2015-10-12 22:59
Reporteruser759Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSUbuntuOS Version13.04
Product Version 
Fixed in Versiondev 
Summary0001023: Possible error in kOmegaSSTSAS
DescriptionI found a possible error in the kOmegaSSTSAS implementation. This is related to a bug report I found here:
http://www.openfoam.org/mantisbt/view.php?id=534

I looks like using omega wall functions was forbidden in the "SAS" version of the model in former OpenFoam versions. Now, in Version 2.2.1, it seems to be allowed, anyhow the computer does not complain about a "type omegaWallFunction;" for the omega boundary.

After looking into the code I recognized, that the line

omegaEqn().boundaryManipulate(omega_.boundaryField());

is missing in the kOmegaSSTSAS.C, but you can find it in the mOmegaSST.C file of the equivalent RAS model.
Now, for the RAS model it is recommended to use the omega wall function, even for the y+=1 (low Re) case, since it implements the correct omega boundary condition for both the low and the high Re case. Shouldn't that not also be valid for the SAS model?

To cut the chase: I think, the wall function evaluation is missing in the kOmegaSSTSAS turbulence model.

Philipp
Steps To Reproducelook into the code
TagsNo tags attached.

Activities

wyldckat

2015-10-12 22:59

updater   ~0005393

As far as I can figure out, this issue is already fixed in OpenFOAM-dev, with the revamped turbulence models as templates, because kOmegaSSTSAS is now derived from kOmegaSST, using the same exact correct() method from kOmegaSST.

Issue History

Date Modified Username Field Change
2013-09-19 14:49 user759 New Issue
2015-10-12 22:59 wyldckat Note Added: 0005393
2015-10-12 22:59 wyldckat Status new => closed
2015-10-12 22:59 wyldckat Assigned To => henry
2015-10-12 22:59 wyldckat Resolution open => fixed
2015-10-12 22:59 wyldckat Fixed in Version => dev