View Issue Details

IDProjectCategoryView StatusLast Update
0000890OpenFOAM[All Projects] Bugpublic2015-01-01 14:16
ReporterdferreterAssigned Tohenry 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
PlatformVirtual BoxOSubuntuOS Version12.04 lts
Product Version 
Fixed in Version 
Summary0000890: ./Allwmake ERROR: ParaView not found in ...
Description./Allwmake ERROR: ParaView not found in ...
Steps To Reproducefollow tutorial from Ubuntu Deb Pack Installation, in "getting started" do:

cd $FOAM_RUN/tutorials/incompressible/icoFoam/cavity
blockMesh
icoFoam
paraFoam

result from paraFoam fault and build suggestion pasted below
Additional Informationdamon@damon-VirtualBox:~/OpenFOAM/damon-2.2.0/run/tutorials/incompressible/icoFoam/cavity$ paraFoam

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
./Allwclean
./Allwmake

damon@damon-VirtualBox:~/OpenFOAM/damon-2.2.0/run/tutorials/incompressible/icoFoam/cavity$ ^C
damon@damon-VirtualBox:~/OpenFOAM/damon-2.2.0/run/tutorials/incompressible/icoFoam/cavity$ cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
damon@damon-VirtualBox:/opt/openfoam220/applications/utilities/postProcessing/graphics/PV3Readers$ ./Allwclean
+ wclean libso vtkPV3Readers
wclean vtkPV3Readers
+ PV3blockMeshReader/Allwclean
+ rm -f /opt/openfoam220/platforms/linuxGccDPOpt/lib/libPV3blockMeshReader*
+ rm -rf PV3blockMeshReader/Make
+ wclean libso vtkPV3blockMesh
wclean vtkPV3blockMesh
+ PV3FoamReader/Allwclean
+ rm -f /opt/openfoam220/platforms/linuxGccDPOpt/lib/libPV3FoamReader*
+ rm -rf PV3FoamReader/Make
+ wclean libso vtkPV3Foam
wclean vtkPV3Foam
damon@damon-VirtualBox:/opt/openfoam220/applications/utilities/postProcessing/graphics/PV3Readers$ ./Allwmake
ERROR: ParaView not found in /opt/paraviewopenfoam3120
TagsNo tags attached.

Activities

dferreter

2013-07-10 19:36

reporter   ~0002318

ping?

wyldckat

2013-07-10 20:37

updater   ~0002319

Does this command give you any errors?

  sudo apt-get install paraviewopenfoam3120

It's step #4 from the official instructions: http://www.openfoam.org/download/ubuntu.php

dferreter

2013-07-10 23:22

reporter   ~0002320

Doesn't look like it.

damon@damon-VirtualBox:~$ sudo apt-get install paraviewopenfoam3120
[sudo] password for damon:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  paraviewopenfoam3120
0 upgraded, 1 newly installed, 0 to remove and 31 not upgraded.
Need to get 44.5 MB of archives.
After this operation, 154 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  paraviewopenfoam3120
Install these packages without verification [y/N]? y
Get:1 http://www.openfoam.org/download/ubuntu/ precise/main paraviewopenfoam3120 i386 0-1 [44.5 MB]
Fetched 35.8 MB in 3min 24s (175 kB/s)
Selecting previously unselected package paraviewopenfoam3120.
(Reading database ... 203442 files and directories currently installed.)
Unpacking paraviewopenfoam3120 (from .../paraviewopenfoam3120_0-1_i386.deb) ...
Setting up paraviewopenfoam3120 (0-1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
damon@damon-VirtualBox:~$

wyldckat

2013-07-11 00:03

updater   ~0002321

Uhm... well, now you do have ParaView installed!
Start a new terminal and try the tutorial once again!

user817

2013-12-26 00:00

  ~0002706

I'm unable to load paraviewopenfoam3120, actually. I'm not on ubuntu but debian, so I'm not able to attempt to get the paraviewopenfoam3120 from the repository.

Please someone address this problem. Thank you.

wyldckat

2013-12-26 00:50

updater   ~0002707

@ivan-s: Please indicate the specific steps you've taken, so that others can reproduce the same steps. That way it'll be possible to diagnose what is happening in your situation.

user817

2013-12-26 01:17

  ~0002708

First, thank you so much for answering my question so quickly during the holiday season.

The specific steps. I'll start with the output from uname -a:
Linux home02 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1+deb7u1 x86_64 GNU/Linux

I followed the steps found on this page:
http://openfoam.org/download/source.php
I started here because there wasn't a Debian-oriented ".deb" distribution available.

I began by installing a whole bitbucket of debian packages as described under what is required for "Ubuntu."

Next, I successfully compiled OpenFOAM as well as "ThirdParty." I then started working with the tutorial found here:
http://www.openfoam.org/docs/user/cavity.php#x5-40002.1

I got to section 2.1.2, which required typing the command:
paraFoam -case $FOAM_RUN/tutorials/incompressible/icoFoam/cavity

This produces:
FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
./Allwclean
./Allwmake

which is very much similar to what is described here. Attempting to follow those instructions then leads to:

ivan@home02:~/OpenFOAM$ cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
ivan@home02:~/OpenFOAM/OpenFOAM-2.2.2/applications/utilities/postProcessing/graphics/PV3Readers$ ls
Allwclean Allwmake PV3blockMeshReader PV3FoamReader vtkPV3Readers
ivan@home02:~/OpenFOAM/OpenFOAM-2.2.2/applications/utilities/postProcessing/graphics/PV3Readers$ ./Allwmake
ERROR: ParaView not found in /home/ivan/OpenFOAM/ThirdParty-2.2.2/platforms/linux64Gcc/paraview-3.12.0
ivan@home02:~/OpenFOAM/OpenFOAM-2.2.2/applications/utilities/postProcessing/graphics/PV3Readers$

I have tried to build ParaFoam from scratch, but that led me to "CUDA_TOOLKIT_ROOT_DIR not found" error... Again, CUDA is set up for Ubuntu, so I'd have to build it for Debian.

It's getting pretty frustrating, thank you so much for the help.

user817

2013-12-26 01:20

  ~0002709

At this point, I'm not quite sure CUDA is really something I want, since I have an ATI card in this machine. But that's a serious tangent.

wyldckat

2013-12-26 15:37

updater   ~0002710

@ivan-s: Something very strange is going on with your installation, because CUDA shouldn't be necessary for building ParaView.

From what I can figure out from the kernel number 3.2.46, you've got one of Debian's 7.x versions (codename Wheezy). And as far as I know, it's somewhat similar to Ubuntu 12.10, therefore I suggest that you try out these (unofficial) instructions: http://openfoamwiki.net/index.php/Installation/Linux/OpenFOAM-2.2.2/Ubuntu#Ubuntu_12.10

user817

2013-12-29 17:08

  ~0002714

I've managed to get it to the point where I install openfoam222.

However, my disk is partitioned such that all the space in '/' gets consumed during the apt-get install process, so the process crashes. There is enough space in /var. I've linked /opt to /home/opt since the /home partition is huge. So /opt isn't the problem. My partitions are /, /home, /tmp, /usr, and /var.

Where is everything getting unpacked? If I know where things are being unpacked then I can link that to /home, too.

user817

2013-12-29 17:12

  ~0002715

I still just wish this bug were fixed.

wyldckat

2013-12-29 17:16

updater   ~0002716

@ivan-s: This doesn't look like a bug report, it looks more like a request for support.

From here, you have at least two options:
 1. Request paid support from the official development team: http://www.openfoam.com/support/

 2. Ask for free support on a public forum, by creating a new thread in it. For example, on this forum: http://www.cfd-online.com/Forums/openfoam-installation/


Disclaimer: I am _not_ part of the official development team, as indicated here in the bug tracker to the left: «wyldckat (reporter)»

user817

2013-12-29 22:15

  ~0002717

Thanks!

user817

2013-12-30 06:58

  ~0002718

Mmm. In the end I did finally get the package to install:

root@home02:/home/ivan# dpkg --install openfoam222_0-1_amd64.deb
(Чтение базы данных … на данный момент установлено 285349 файлов и каталогов.)
Подготовка к замене пакета openfoam222 0-1 (используется файл openfoam222_0-1_amd64.deb) …
Распаковывается замена для пакета openfoam222 …
Настраивается пакет openfoam222 (0-1) …

** To use OpenFOAM please add
**
** . /opt/openfoam222/etc/bashrc
**
** To your ~/.bashrc


However, it still reports the same bug (after adding that line to my .bashrc file and restarting a terminal):

ivan@home02:~$ paraFoam

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
./Allwclean
./Allwmake

So it looks like the same bug. Thanks for the help.

wyldckat

2013-12-30 23:33

updater   ~0002721

Last edited: 2013-12-31 00:53

View 2 revisions

I've finished testing Debian Wheezy 7.3 x86_64 on a virtual machine and even tried with the repository for "proposed updates" turned on. It simply did not allow me to install the OpenFOAM 2.2.2 from the Deb package, namely the one meant for Ubuntu Quantal (12.10), because the libc6 version on Debian 7.3 was too old.

What specific Debian version and modifications are you using on your system?


By the way, have you tried running with the "-builtin" option? Namely:
  paraFoam -builtin

----------------------
edit: I installed Debian Jessie x86_64 in a virtual machine and with some tinkering I managed to install the OpenFOAM+ParaView Deb packages meant for Ubuntu Saucy. And the reported bug with paraFoam did not occur.

user817

2013-12-31 03:28

  ~0002723

I loaded libc6 from testing, it was not too difficult. Then I was able to load openfoam222 for quantal. I haven't tried using the -builtin option, but here is the result:

ivan@home02:~/OpenFOAM/ivan-2.2.2/run/tutorials/incompressible/icoFoam$ paraFoam -builtin
created temporary 'icoFoam.foam'
/opt/openfoam222/bin/paraFoam: 267: /opt/openfoam222/bin/paraFoam: paraview: not found

wyldckat

2013-12-31 11:53

updater   ~0002727

"paraview: not found" - I would say that this message pretty much says it all, given that since ParaView is not installed, there isn't much that can be done.

From this point, you have two options:

 1. Forcefully install all necessary packages from the testing repositories, so that the package "paraviewopenfoam3120" will install. Of course this could break your system, so that's at your own responsibility.

 2. Install the "paraview" package from the official Debian repositories and then use the "-builtin" option. And if you don't want to have to write the "-builtin" option every time, you can either edit the file "bin/paraFoam" to always use that option; or you can add this alias to your ".bashrc" file:
   alias paraFoam='paraFoam -builtin'


--------------------------------
@OpenFOAM team: I guess that the actual bug report is that the error message given by paraFoam should be clearer, by checking first if there is any ParaView at all available and complaining about it first; and then to try and use the "-builtin" option automatically and warning that this option is being used.
If you want, I can suggest a patch for it.

user817

2014-01-02 05:27

  ~0002734

I just tried to load paraviewopenfoam3120 and it worked. I didn't have to force any more packages. So in total the only change to my system required was the addition of libc-6 >= 2.14.

Thank you for the help. paraFoam lit off, seemingly correctly, and I should be able to work through the tutorials.

Issue History

Date Modified Username Field Change
2013-06-13 22:17 dferreter New Issue
2013-07-10 19:36 dferreter Note Added: 0002318
2013-07-10 20:37 wyldckat Note Added: 0002319
2013-07-10 23:22 dferreter Note Added: 0002320
2013-07-11 00:03 wyldckat Note Added: 0002321
2013-12-26 00:00 user817 Note Added: 0002706
2013-12-26 00:50 wyldckat Note Added: 0002707
2013-12-26 01:17 user817 Note Added: 0002708
2013-12-26 01:20 user817 Note Added: 0002709
2013-12-26 15:37 wyldckat Note Added: 0002710
2013-12-29 17:08 user817 Note Added: 0002714
2013-12-29 17:12 user817 Note Added: 0002715
2013-12-29 17:16 wyldckat Note Added: 0002716
2013-12-29 22:15 user817 Note Added: 0002717
2013-12-30 06:58 user817 Note Added: 0002718
2013-12-30 23:33 wyldckat Note Added: 0002721
2013-12-31 00:53 wyldckat Note Edited: 0002721 View Revisions
2013-12-31 03:28 user817 Note Added: 0002723
2013-12-31 11:53 wyldckat Note Added: 0002727
2014-01-02 05:27 user817 Note Added: 0002734
2015-01-01 14:16 henry Status new => resolved
2015-01-01 14:16 henry Resolution open => no change required
2015-01-01 14:16 henry Assigned To => henry