View Issue Details

IDProjectCategoryView StatusLast Update
0000877OpenFOAM[All Projects] Bugpublic2015-02-02 20:44
Reporteruser674Assigned Touser4 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSDebianOS Version4.6.3-15
Product Version 
Fixed in Version 
Summary0000877: checkMesh non-orthogonality fails after createPatch
DescriptionCreating a hybrid mesh in gmsh and conversion to OpenFoam using gmshToFoam works properly (checkMesh does not complain). After using createPatch the non-orthogonality check of checkMesh fails (non-orthogonality ~180). You find the isolated non-orthogonal faces attached, those are the cyclics.

This is only the case for the new OpenFoam Version 2.2.0 in the older version everything worked fine and checkMesh did not complain. The computation on the grid seems to work.
Steps To ReproduceI am not sure if this only occurs for gmsh meshes. It should be easily reproducible following the steps mentioned above.
TagsNo tags attached.

Activities

user674

2013-06-05 07:43

 

pzmcyr5v9ucg.jpg (43,255 bytes)
pzmcyr5v9ucg.jpg (43,255 bytes)

nogenmyr

2013-06-10 07:01

reporter   ~0002266

Maybe related to this? http://www.openfoam.org/mantisbt/view.php?id=809

user674

2013-06-10 07:59

  ~0002267

Yes, seems to be the same problem. Sorry for double posting.

user4

2015-02-02 20:44

  ~0003657

Fixed in 22x in a1264baad44158d49c262db1350b16f19ab0331c

Issue History

Date Modified Username Field Change
2013-06-05 07:43 user674 New Issue
2013-06-05 07:43 user674 File Added: pzmcyr5v9ucg.jpg
2013-06-10 07:01 nogenmyr Note Added: 0002266
2013-06-10 07:59 user674 Note Added: 0002267
2015-02-02 20:44 user4 Note Added: 0003657
2015-02-02 20:44 user4 Status new => resolved
2015-02-02 20:44 user4 Fixed in Version => 2.2.x
2015-02-02 20:44 user4 Resolution open => fixed
2015-02-02 20:44 user4 Assigned To => user4