View Issue Details

IDProjectCategoryView StatusLast Update
0000858OpenFOAM[All Projects] Bugpublic2015-01-01 17:13
Reporteruser661Assigned Tohenry 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000858: Wrong "sample" utility help and example
DescriptionI would like to report two errors in the "sample" utility help and in the sampleDict of an example.

The first one can be seen typing sample -help. The help says:
-time <ranges> comma-separated time ranges - eg, ':10,20,40-70,1000:'
while the ' -time 40-70 ' option doesn't work

The second one is in the
$FOAM_TUTORIALS/stressAnalysis/solidDisplacementFoam/plateHole/system/sampleSurfaceDict

moving this to 'sampleDict' and running the case, returns the error

keyword type is undefined in dictionary .../system/sampleDict::surfaces

that can be fixed adding 'type plane' to that dictionary.


PS: i'm not an expert of OF and I report these two "bugs" because they confused me while I was trying to use the sample utility for the first time. If they are ment to be like this just ignore this report.

Best regards,
Luca Amerio
Tagssample

Activities

henry

2015-01-01 17:12

manager   ~0003458

Resolved by commit 5a935874b030587d8da6f7fc6f8ecf7399c8ce33

Issue History

Date Modified Username Field Change
2013-05-21 06:53 user661 New Issue
2014-12-29 18:38 wyldckat Tag Attached: sample
2015-01-01 17:12 henry Note Added: 0003458
2015-01-01 17:12 henry Status new => resolved
2015-01-01 17:12 henry Resolution open => fixed
2015-01-01 17:12 henry Assigned To => henry