View Issue Details

IDProjectCategoryView StatusLast Update
0000084OpenFOAM[All Projects] Bugpublic2011-09-14 12:44
Reporteruser81Assigned Touser2 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000084: while restarting rhoPisoTwinParcelFoam origId of kinematicParcels isn't imported correctly
Descriptionif restarting rhoPisoTwin ParcelFoam produces new origIds for kinematicParcels
-- seems as if counting up from last time step

example:
old time step: ( 0 1 2 3 4 )
new time step: ( 5 6 7 8 9 )
Steps To Reproduce- run rhoPisoTwinParcelFoam on simplifiedSiwek tutorial
- stop the solver after one time-step is written on disk
- check origIds of kinematicParcels of the last time step
- restart rhoPisoTwinParcelFoam
- check a new time directory
-> origIds have changed (counted up from last time step)

example:
old time step: ( 0 1 2 3 4 )
new time step: ( 5 6 7 8 9 )
Additional Informationmaybe the problem is in the constructor of either the cloud class or the kinematicParcel

seems that function getNewParcelID() is called although the parcel has an origId
or
the mutable label particleCount_ isn't set to zero while restarting solver?
TagsNo tags attached.

Activities

user2

2011-09-14 12:44

  ~0000656

Particle origId behaviour on restart has been corrected in the latest version (OF 2.0 series)

Issue History

Date Modified Username Field Change
2010-11-19 15:20 user81 New Issue
2010-11-23 09:53 user2 Assigned To => user2
2010-11-23 09:53 user2 Status new => assigned
2010-12-16 10:12 user2 Assigned To user2 =>
2010-12-16 10:12 user2 Status assigned => acknowledged
2011-09-14 12:44 user2 Note Added: 0000656
2011-09-14 12:44 user2 Status acknowledged => resolved
2011-09-14 12:44 user2 Fixed in Version => 2.0.x
2011-09-14 12:44 user2 Resolution open => fixed
2011-09-14 12:44 user2 Assigned To => user2