View Issue Details

IDProjectCategoryView StatusLast Update
0000079OpenFOAM[All Projects] Bugpublic2011-06-28 13:17
ReporterwyldckatAssigned Tohenry 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000079: Minor glitches in ThirdParty's Allwmake, related to libscotch and "make" in MPI's
DescriptionThe first issue is that when doing a completely clean build of OpenFOAM, libscotch and libptscotch don't get copied to the target folders, because when doing a completely new build, the folders haven't been created by wmake yet. Therefore, some libraries and applications aren't built on the first run. A second run goes well, because the target folders already exist.

The second issue is that on a multi-core computer, building OpenMPI (or MPICH/MPICH2) via Allwmake takes a long time to build, because only one core is used.
Additional InformationAttached is a proposed patch for both of these issues. The patch attached isn't signed because they are very basic fixes.
TagsNo tags attached.

Activities

wyldckat

2010-11-14 21:17

updater  

ThirdParty_Allwmake.diff.gz (716 bytes)

wyldckat

2011-06-17 22:37

updater   ~0000447

Greetings,

Similar to what happened with report #96 ( http://www.openfoam.com/mantisbt/view.php?id=96 ), this issue has already been fixed in OpenFOAM 2.0.0 as well.

Best regards,
Bruno

wyldckat

2011-06-22 09:14

updater   ~0000473

I reiterate, there is something that sooner or later is going to be reported as a bug for 2.0.x:
When it comes to ptscotch, it's missing this section of code from scotch:

    # this needs generalizing
    makeFile=../../etc/wmakeFiles/scotch/Makefile.inc.i686_pc_linux2.shlib-OpenFOAM

    if [ -f $makeFile -a ! -f Makefile.inc ]
    then
        rm -f Makefile.inc
        ln -s $makeFile Makefile.inc
    fi


If it's not present, in case the user wants to only link up with another MPI library and for some reason "Makefile.inc" has disappeared, then ptscotch won't build.

henry

2011-06-28 13:17

manager   ~0000495

Thanks for the bug-report.

The issues relating to the build of scotch and ptscotch are resolved by commit 2f1333de3f99cecf931f850f949716bcad87c0da

Issue History

Date Modified Username Field Change
2010-11-14 21:17 wyldckat New Issue
2010-11-14 21:17 wyldckat File Added: ThirdParty_Allwmake.diff.gz
2011-06-17 22:37 wyldckat Note Added: 0000447
2011-06-22 09:14 wyldckat Note Added: 0000473
2011-06-28 13:17 henry Note Added: 0000495
2011-06-28 13:17 henry Status new => resolved
2011-06-28 13:17 henry Resolution open => fixed
2011-06-28 13:17 henry Assigned To => henry