View Issue Details

IDProjectCategoryView StatusLast Update
0000626OpenFOAM[All Projects] Bugpublic2012-08-15 15:45
Reporteruser496Assigned Touser2 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000626: Missing file DataEntryFwd.H in 2.1.x git downloaded 8/15/12 9am CST
Description+ wmake libso OpenFOAM
SOURCE=primitives/functions/DataEntry/polynomial/polynomial.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -IlnInclude -I. -I/home/wardke/OpenFOAM/OpenFOAM-2.1.x/src/OpenFOAM/lnInclude -I/home/wardke/OpenFOAM/OpenFOAM-2.1.x/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/polynomial.o
In file included from primitives/functions/DataEntry/polynomial/polynomial.C:26:0:
primitives/functions/DataEntry/polynomial/polynomial.H:48:26: fatal error: DataEntryFwd.H: No such file or directory
compilation terminated.
make: *** [Make/linux64GccDPOpt/polynomial.o] Error 1
TagsNo tags attached.

Activities

wyldckat

2012-08-15 15:36

updater   ~0001595

Try these commands:
  wclean libso $FOAM_SRC/OpenFOAM
  wmake libso $FOAM_SRC/OpenFOAM

The "DataEntryFwd.H" file was added for the bug report #607: http://www.openfoam.org/mantisbt/view.php?id=607

user496

2012-08-15 15:41

  ~0001596

That did the trick. Didn't realize you need to wclean after a new git pull.

user2

2012-08-15 15:45

  ~0001597

To wclean or not will depend on the level and type of changes since the last time you updated your local repository

Issue History

Date Modified Username Field Change
2012-08-15 15:31 user496 New Issue
2012-08-15 15:36 wyldckat Note Added: 0001595
2012-08-15 15:41 user496 Note Added: 0001596
2012-08-15 15:45 user2 Note Added: 0001597
2012-08-15 15:45 user2 Status new => resolved
2012-08-15 15:45 user2 Fixed in Version => 2.1.x
2012-08-15 15:45 user2 Resolution open => no change required
2012-08-15 15:45 user2 Assigned To => user2