View Issue Details

IDProjectCategoryView StatusLast Update
0000056OpenFOAM[All Projects] Bugpublic2010-10-15 10:01
Reporteruser54Assigned Touser4 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000056: Crash using DirectMapped* boundary conditions and nearestFace
DescriptionFurther to bug #0000050, there still seems to be a problem with the directMapped and directMappedVelocityFlux boundary conditions, when the nearestFace option in changeDictionaryDict is chosen. new*Values are written out in the incorrect position in the NEARESTFACE case in directMappedVelocityFluxFixedValueFvPatchField.C, and
directMappedFixedValueFvPatchField.C.

I have attached a tarball containing what I believe to be fixed versions of both of these files.

James
TagsNo tags attached.

Activities

user54

2010-10-14 07:55

 

directMapped.tar.gz (3,043 bytes)

user54

2010-10-14 08:07

  ~0000079

Also, should the mapDistribute's be changed too?


(directMappedFixedValueFvPatchField.C:260)
            mapDistribute::distribute
            (
                Pstream::defaultCommsType,
                distMap.schedule(),
                distMap.constructSize(),
                distMap.subMap(),
                distMap.constructMap(),
                newValues //instead of allValues?
            );

and,

(directMappedVelocityFluxFixedValueFvPatchField.C:191)

            newUValues = patch().patchSlice(allUValues);
            mapDistribute::distribute
            (
                Pstream::defaultCommsType,
                distMap.schedule(),
                distMap.constructSize(),
                distMap.subMap(),
                distMap.constructMap(),
                newUValues // instead of allUValues
            );
            
            newPhiValues = patch().patchSlice(allPhiValues);
            mapDistribute::distribute
            (
                Pstream::defaultCommsType,
                distMap.schedule(),
                distMap.constructSize(),
                distMap.subMap(),
                distMap.constructMap(),
                newPhiValues // instead of allPhiValues
            );

user4

2010-10-14 09:56

  ~0000080

I've pushed a fix to 17x. The problem was that the mapDistribute was already compacting the needed values so we can just .transfer() them. Attached a testprogram and case. blockMesh it, change the 'in' type to nearestPatch and run the program. For testing it maps the face-centres of the 'out' patch onto the 'in' patch.

Thanks for persevering.

user4

2010-10-15 10:01

  ~0000081

commit f12de259edcfc622c780f503b94dd8a0539d8135

Issue History

Date Modified Username Field Change
2010-10-14 07:55 user54 New Issue
2010-10-14 07:55 user54 File Added: directMapped.tar.gz
2010-10-14 08:07 user54 Note Added: 0000079
2010-10-14 08:50 user4 Assigned To => user4
2010-10-14 08:50 user4 Status new => assigned
2010-10-14 09:56 user4 Note Added: 0000080
2010-10-15 10:01 user4 Note Added: 0000081
2010-10-15 10:01 user4 Status assigned => resolved
2010-10-15 10:01 user4 Resolution open => fixed