View Issue Details

IDProjectCategoryView StatusLast Update
0000541OpenFOAM[All Projects] Bugpublic2012-06-06 13:37
ReporterwyldckatAssigned Touser4 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000541: surfaceFeatureConvert can't handle binary eMesh files
DescriptionWhile diagnosing if there was any problem with an eMesh file, by converting eMesh to obj, it was discovered that surfaceFeatureConvert can't handle binary eMesh files.

The error message from surfaceFeatureConvert:
  --> FOAM FATAL IO ERROR:
  Expected a '(' while reading VectorSpace<Form, Cmpt, nCmpt>, found on line 25 an error

  file: constant\triSurface\Volume_0.eMesh at line 25.

  From function Istream::readBegin(const char*)
  in file db/IOstreams/IOstreams/Istream.C at line 94.

  FOAM exiting
Steps To Reproduce./Allrun each of the attached cases and check the files log.surfaceFeatureConvert for information.
Additional InformationThis was discovered while trying to help on this forum thread: http://www.cfd-online.com/Forums/openfoam-meshing-snappyhexmesh/102252-snappyhexmesh-problem-meshing-baffle-surface-zero-thickness.html

It's a very thin surface to be meshed with snappyHexMesh... not sure if that should also be reported as another bug or not, but you can check the resulting mesh to see the problem. Either way, the solution on that issue seems to be to generate a better base mesh.
TagsNo tags attached.

Activities

wyldckat

2012-05-27 13:03

updater  

Volume_0_binary.tar.gz (2,993 bytes)

wyldckat

2012-05-27 13:03

updater  

Volume_0_ascii.tar.gz (2,979 bytes)

user4

2012-06-06 13:37

  ~0001362

Fixed in 61df796847d18c42b2c6f881710debfd9b94bd22.

It now checks the header to determine the type of the file. Thanks for reporting.

Issue History

Date Modified Username Field Change
2012-05-27 13:03 wyldckat New Issue
2012-05-27 13:03 wyldckat File Added: Volume_0_binary.tar.gz
2012-05-27 13:03 wyldckat File Added: Volume_0_ascii.tar.gz
2012-06-06 13:37 user4 Note Added: 0001362
2012-06-06 13:37 user4 Status new => resolved
2012-06-06 13:37 user4 Fixed in Version => 2.1.x
2012-06-06 13:37 user4 Resolution open => fixed
2012-06-06 13:37 user4 Assigned To => user4