View Issue Details

IDProjectCategoryView StatusLast Update
0000053OpenFOAM[All Projects] Bugpublic2010-10-07 18:00
Reporteruser48Assigned Touser4 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000053: decomposePar does not work when used with scotch/metis and preserveFaceZones
DescriptionDear developpers,

The decomposePar utility send an error message (see below) when the method metis or scotch is used with the preserveFaceZones entry in the decomposeParDict file. However, the decomposition method simple supports the preserveFaceZones entry. Furthermore, the problem does not appear when the same procedure is used in OpenFOAM-1.6.x.
Steps To ReproduceSimply extract the archive and execute the decomposeCase script included within the case directory. This script executes the following commands:

blockMesh
faceSet
setsToZones -noFlipMap
decomposePar -force

Again, this script works in OpenFOAM-1.6.x but not in OpenFOAM-1.7.x.
Additional Information/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 1.7.x |
| \\ / A nd | Web: www.OpenFOAM.com |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Build : 1.7.x-a173785491bb
Exec : decomposePar -force
Date : Oct 05 2010
Time : 12:52:17
Host : lmfnpc19
PID : 10754
Case : /home/maoli24/Desktop/cavityBlock
nProcs : 1
SigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Time = 0
Create mesh

Calculating distribution of cells
Keeping owner and neighbour of faces in zones
1
(
f1
)
 on same processor
Selecting decompositionMethod scotch
Selected 2536 faces whose owner and neighbour cell should be kept on the same processor


--> FOAM FATAL ERROR:
Can use this decomposition method only for the whole mesh
and supply one coordinate (cellCentre) for every cell.
The number of coordinates 1
The number of cells in the mesh 620

    From function scotchDecomp::decompose(const pointField&, const scalarField&)
    in file scotchDecomp.C at line 435.

FOAM exiting
TagsPre-processing, Utility

Activities

user48

2010-10-05 18:11

 

cavityBlock.tgz (2,921 bytes)

user4

2010-10-05 21:54

  ~0000069

I think this was fixed very recently (30 Sept) in commit be1f2f69. I see no error messages.

user48

2010-10-06 15:24

  ~0000072

Indeed ! I updated OpenFOAM-1.7.x to the latest version and the problem is fixed. Thank you.

Issue History

Date Modified Username Field Change
2010-10-05 18:11 user48 New Issue
2010-10-05 18:11 user48 File Added: cavityBlock.tgz
2010-10-05 21:54 user4 Note Added: 0000069
2010-10-06 15:24 user48 Note Added: 0000072
2010-10-06 15:31 user4 Status new => resolved
2010-10-06 15:31 user4 Fixed in Version => 1.7.x
2010-10-06 15:31 user4 Resolution open => no change required
2010-10-06 15:31 user4 Assigned To => user4
2010-10-07 18:00 user2 Tag Attached: Pre-processing
2010-10-07 18:00 user2 Tag Attached: Utility